Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-24-2016, 08:15 PM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
95 E320 Throttle Eratic... Sometimes. What could it be?

My ASR and ABS light are on at times and once in a while the throttle acts up. It will not go until I floor it then it reacts but seems like a bad pot or something. It's really eratic. Then I'll start it up and drive more and all is well. What are some possibilities?
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!
Reply With Quote
  #2  
Old 10-24-2016, 08:29 PM
Registered User
 
Join Date: Oct 2016
Posts: 142
You'll find lots of comments about faulty wiring..both the engine harness and the ETA unit itself..I find a couple guys rewiring these units for about $400..If the wiring is bad be careful inspecting it BC you can kill a functional unit by disturbing the bad insulation causing the faults you are finding..

But if your ETA is good..Hmm ASR and ABS lights on..a bit scary!

Good luck, let us know..I have ASR as well and so far so good..Thanks to the previous owner putting in a new ETA..
Reply With Quote
  #3  
Old 10-24-2016, 08:34 PM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
Quote:
Originally Posted by puzzler View Post
..

But if your ETA is good..Hmm ASR and ABS lights on..a bit scary!

...
What do you mean by this? I know what ABS is but not familiar with ASR? So I don't know enough to know why it could be a bit scary.

I know diesels mostly.
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!
Reply With Quote
  #4  
Old 10-25-2016, 07:32 AM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
Could this mean my ASR and ABS system is to blame? The throttle will do nothing until WOT then it will jump and then back down to nothing if I back off. It's like a 0 1 0 1 0 1 (off on off on off on) thing with the engine's power as I try to maintain speed.
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!
Reply With Quote
  #5  
Old 10-25-2016, 10:25 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 2,970
777funk, it's possible that worn voltage regulator brushes are affecting proper charging of the battery and the ABS & ASR lights are illuminating. You may want to inspect the voltage regulator brushes, especially if you have never replaced the voltage regulator.
__________________
Fred Hoelzle
Reply With Quote
  #6  
Old 10-25-2016, 08:46 PM
Registered User
 
Join Date: Oct 2016
Posts: 142
Hi Funk..I thought you said your ASR light was on, the yellow triangle? Slip resistance system which keeps one wheel from spinning and comes on if you hit gravel or ice. Its an optional feature I understand and I think my 94 coupe did not have it but the 95 wagon I have does have it..Maybe I misread your post about warning lights..All I know is the ASR cars are more computerized and have an ASR module which can cause issues and the engine control through the electronic throttle is more complicated. Troubleshooting my wont start issue I suspected the throttle and everyone wanted to know if it was ASR or non ASR..

good luck, keep us posted on your success..
Reply With Quote
  #7  
Old 10-26-2016, 10:34 AM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
That's a good point. I will check those brushes. Great starting point (and possibly finishing point). EDIT: I just checked the voltage at the battery with engine on and I get around 14.3 to 14.5V regardless of RPMs. The original owner said it doesn't act up for a while though so maybe eventually it rises. I'll have to monitor this next time there's a throttle issue. The car had bad tires for what that's worth.

I just read for codes and got the following:
PIN 8 Trouble Codes:
9 O2S 1 (before TWC) - voltage too high, circuit open or voltage implausible
11 O2S 1 heater (before TWC) - Current too high/low or short circuit.
42 CAN communication from ASR, EA/CC/ISC module or diagnostic module (OBD II) faulty
46 Resonance intake manifold switchover valve - open/short to ground or B+

Pin 14 Trouble Codes:
2 EA/CC/ISC control module (N4/1) or Safety contact switch (M16/1s1) or Stop lamp
switch or Cruise control switch or Actual value potentiometer or Starter lock-out/back-up
lamp switch or engine speed signal or vehicle speed signal or closed throttle position
switch or safety relay in EA/CC/ISC control module
11 Closed throttle recognition signal to engine control module (HFM-SFI or Left LH-SFI)
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!

Last edited by 777funk; 10-26-2016 at 10:50 AM.
Reply With Quote
  #8  
Old 10-27-2016, 05:41 AM
optimusprime's Avatar
Trevor Hadlington
 
Join Date: May 2014
Location: Worcestershire in England
Posts: 1,161
Clean up the CPS sensor .Engine is getting late signal fron Crank Possition Sensor .Easy job and it will cost you nothing, only time
Reply With Quote
  #9  
Old 10-27-2016, 07:26 AM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
Quote:
Originally Posted by optimusprime View Post
Clean up the CPS sensor .Engine is getting late signal fron Crank Possition Sensor .Easy job and it will cost you nothing, only time
Wow. You sound like you know my symptoms. What is it that tells you what the problem is?

EDIT: to update this. Started it today a few times and everything is good. Then all the sudden it was hunting for idle and no acceleration until I get to WOT. Shut it down and restart... All is well again. Interesting.

EDIT #2: I just took out the crank sensor and it only has a little oil on the outside plastic. The metal magnetic tip looks clean. It does look a little ground. Not sure if it's factory ground or ground by the crank. By the direction of the scratches (fine), it looks like they're a different orientation than how the crank spins.
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!

Last edited by 777funk; 10-27-2016 at 03:24 PM.
Reply With Quote
  #10  
Old 10-31-2016, 12:32 PM
777funk's Avatar
Registered User
 
Join Date: Dec 2006
Posts: 944
Any more ideas?
__________________
-7.3 Powerstroke Diesel 15P Van 500k+ miles
-E320 '95 200k

Sold
-E320 Wagon 1994 155k
-300d Turbo '87 187k miles
-E320 1994 200k
-300d Turbo '84 245k (sold to Dan62)
-300d Turbo '84 180k
-300sd '80 300k
-190d '89 Non Turbo 2.5 5cyl 240k
Tom's Imports of Columbia Missouri Ruined the IP in changing leaky delivery valve O-Rings - Refused to stand behind his work. Mid-MO MB drivers-AVOID Tom's!
Reply With Quote
  #11  
Old 10-31-2016, 01:54 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 548
Next time it dosent accelerate disconnect airmass meter and seet if it does if it makes no difference, try replaceing your overvoltage protection relay , its the big cude looking thing behind battery tray towards firewall area
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page