Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-16-1999, 04:05 AM
Bob Cavazos
Guest
 
Posts: n/a
I have just purchased a pristine '87 560SL. The light in the right (tach/clock) pod doesn't work. How can I replace it? I know the cluster will come out the front, but it looks like the steering wheel is in the way. Can I remove the wheel w/o fear of deploying the air bag? Is it possible to change the lamp by removing the stereo and reaching through the opening? I will be changing out the stereo very soon.
  #2  
Old 04-16-1999, 02:32 PM
Benzmac
Guest
 
Posts: n/a
You will have to remove the steering wheel to replace the illumination bulbs. To do so you will need a Torx T-30 and a 10mm allen on a big ratchet. After removing the air bag carefully remove the small red connector on the back of the bag then place the bag on a clean surface with the Airbag facing up. Get out the 10mm allen and remove the big cone shaped bolt in the center of the wheel and mark the wheel before removal. The wheel will go on many many ways mark it well. Pull out the cluster with some Mercedes dash hooks and there you go.
Good luck.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 04-17-1999, 01:41 PM
Bob Cavazos
Guest
 
Posts: n/a
Thanks for the info. I was able to get the air bag off, but I was not certain how to disconnect the red connector. I tried gently pulling on it, tried rocking it, sliding it, and even tried to open it as it looks like the connector is hinged. Does one just pry it off with a screwdriver? Again, thanks for your earlier reply.
  #4  
Old 04-18-1999, 11:21 PM
Benzmac
Guest
 
Posts: n/a
Yes, I pulls straight up. I insert a small screw driver at the front edge to help..Be sure you're grounded when you do this. One small arc of static and Pow!!

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just "Renewed" the instrument panel, lights and gauges and odometer Eric Eliel Diesel Discussion 21 01-06-2012 01:17 AM
Instrument lights still dead; rheostat bypassed The Warden Diesel Discussion 13 04-08-2005 12:43 PM
Instrument lights dead The Warden Diesel Discussion 2 12-11-2004 11:18 AM
Instrument lights do not dim when head lights are on... hancheng Tech Help 2 04-27-2004 05:01 PM
Instrument Panel Lights - This Worked jcd Diesel Discussion 1 10-22-2001 12:47 PM



All times are GMT -4. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page