Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 04-19-1999, 09:51 PM
Posts: n/a
The blinker on my 1999 500 SL is not functional on the front left. My brother told me my blinker fluid might be low. Where do I fill the blinker fluid?

[This message has been edited by Dax (edited 04-19-99).]
Old 04-19-1999, 10:04 PM
Posts: n/a
Someone is "pulling your leg". Blinkers don't use fluid, they use small light bulbs!!
See your owners manual.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Class problems, problems, problems. Eddie Gilmartin Featured Cars 5 07-21-2005 06:37 PM
Please Help - Unusual Merc problems Chambo Tech Help 0 09-17-2003 11:59 PM
2000 C-Class Problems ---> Please Help rolls88 Tech Help 4 09-12-2003 10:47 AM
Questions about C220 problems j0e Tech Help 2 06-28-2003 01:55 AM
Two problems over the weekend Indy300CE Tech Help 3 03-11-2002 05:33 PM

All times are GMT -4. The time now is 05:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page