Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-12-2019, 10:08 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
w124 m104 need help again

i got everything bolted back together from a head gasket change..fill the fluids..start the car. runs and sounds like absolute ****. leaking coolant from somewhere on the back of the engine ..but not the heater hose, hooked up a vac guage its oscillating from 2-5hg. feels like its only running on 3 cylinders. idles at 800 and revs up pretty quick when you give it gas. no codes..no backfiring..no smoke

ill run a compression check but it kinda seems like i f-ed up my head gasket repair somehow. everything went together smoothly im a lil disappointed and a little bit frustrated

actually it looks like its only leaking from that o-ringed water line under the thermostat. so thats an easy fix.
__________________
1995 e320
1994 e320

Last edited by speednjay; 04-12-2019 at 10:57 PM.
Reply With Quote
  #2  
Old 04-13-2019, 12:04 AM
INSIDIOUS's Avatar
Electron spewer
 
Join Date: Jan 2014
Location: Honah Lee
Posts: 9,419
Thanks for sharing?
Reply With Quote
  #3  
Old 04-13-2019, 12:07 AM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 576
check the coils for correct orientation1/6 2/5 3/4 has the correct way on the cover
Reply With Quote
  #4  
Old 04-13-2019, 12:15 AM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Quote:
Originally Posted by nulu View Post
check the coils for correct orientation1/6 2/5 3/4 has the correct way on the cover
I swapped them around with some spares I had. No change. Exhaust smells rich.


Quote:
Originally Posted by INSIDIOUS View Post
Thanks for sharing?
Was just asking for help/ ideas on how to fix my car
__________________
1995 e320
1994 e320
Reply With Quote
  #5  
Old 04-13-2019, 12:20 AM
INSIDIOUS's Avatar
Electron spewer
 
Join Date: Jan 2014
Location: Honah Lee
Posts: 9,419
It almost sounded as if you solved with the last line "actually it looks like its only leaking from that o-ringed water line under the thermostat. so thats an easy fix. " but maybe not.
Reply With Quote
  #6  
Old 04-13-2019, 02:08 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
What would cause the back 3 cylinders to not fire? I started the engine cold and checked the exhaust ports for heat. Cylinders 4 5 6 are ice cold while 1 2 3 quickly heated up.
__________________
1995 e320
1994 e320

Last edited by speednjay; 04-13-2019 at 03:19 PM.
Reply With Quote
  #7  
Old 04-13-2019, 04:51 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 576
Perform a compression test before further diagnosis
Reply With Quote
  #8  
Old 04-13-2019, 06:06 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Cylinder 6 has zero compression. Guess I need to do a leak down test now to figure out exactly what’s going on. Maybe a valve got damaged somehow?
__________________
1995 e320
1994 e320

Last edited by speednjay; 04-13-2019 at 06:57 PM.
Reply With Quote
  #9  
Old 04-15-2019, 09:52 AM
Registered User
 
Join Date: Aug 2017
Location: South NJ
Posts: 81
How did you time? did you verify the positions of the cams with a 4mm pin flat against the head surface? crank at OT? intake sprocket turned CW?
Reply With Quote
  #10  
Old 04-15-2019, 10:07 AM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Quote:
Originally Posted by ytech15 View Post
How did you time? did you verify the positions of the cams with a 4mm pin flat against the head surface? crank at OT? intake sprocket turned CW?
Yup did everything. Iím 100 percent the timing is spot on. I checked.. rotated the engine double checked.. rotated a few times checked again. Variable Intake cam sprocket turned clockwise. I ran a shope inside and thereís no physical damage. Piston top is untouched.
__________________
1995 e320
1994 e320
Reply With Quote
  #11  
Old 04-15-2019, 11:09 AM
Registered User
 
Join Date: Aug 2017
Location: South NJ
Posts: 81
Post the compression data of all 6 cyl with spark plugs removed. Obviously there is a mechanical fault (since 0 compression at cyl #6) I would get that sorted first.
Reply With Quote
  #12  
Old 04-15-2019, 12:09 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Ok Iíll do that after work.

The only thing I can think of is that I put a lil bit of oil on the cylinder walls .. maybe it pooled on the piston and hydro locked or I had an issue with the exhaust cam being out of timing when I installed the head. I didnít force anything. Maybe that was enough to bend a valve a little.
__________________
1995 e320
1994 e320
Reply With Quote
  #13  
Old 04-20-2019, 08:31 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Head is off. Number 6 valves are bent a lil. Not fully seating.
__________________
1995 e320
1994 e320
Reply With Quote
  #14  
Old 04-20-2019, 08:52 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 576
what about cylinders 4,5 ?better check all of them, did you get a head gasket yet ? I may have 1 ill donate to your cause, im an mb tech was given about 4 104 gaskets from another engine guy that moved, im in L.A, just come pick it up im off Monday, I even have used valves if you need them
Reply With Quote
  #15  
Old 04-20-2019, 09:13 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 321
Quote:
Originally Posted by nulu View Post
what about cylinders 4,5 ?better check all of them, did you get a head gasket yet ? I may have 1 ill donate to your cause, im an mb tech was given about 4 104 gaskets from another engine guy that moved, im in L.A, just come pick it up im off Monday, I even have used valves if you need them
Number 4 and 5 appear to be ok. Iíll have the shop check everything. I was going to do a big pelican parts order next Friday. I probably could use those valves tho. The machine shop will definitely charge me a good penny for theirs. What part of la? Itíll be about a 2+ hour drive for me
__________________
1995 e320
1994 e320
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page