Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-1999, 03:57 PM
Randy
Guest
 
Posts: n/a
I have a '91 500SL losing power steering fluid. The hose from the reservoir to the pump appears moist, but not running wet. The system loses quite a bit fairly quickly. Have there been problems with these pumps? I believe I can get the pump off the car. If it is the pump, is it just a matter of replacing a gasket between the pump body halves? If it is more involved, are there rebuild kits available? Should you take apart a pump at home?
  #2  
Old 05-09-1999, 08:24 PM
MB STARS
Guest
 
Posts: n/a
Have you check the power steering gear box is leaks fluid.
  #3  
Old 05-09-1999, 11:10 PM
Benzmac
Guest
 
Posts: n/a
The power steering sector does leak on these models, however more often than not it is the hose that connects the reservoir to the pump that does most of the leaking. If you do determine that the pump is the leak though, the pump reseal kit contains 0-rings that will reseal the halves.
OH yeah, If you take off the poly belt beware of the tensioner. I have seen a number of these fail without warning!

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM




[This message has been edited by Benzmac (edited 05-09-99).]
  #4  
Old 05-11-1999, 10:32 AM
Fred Berry
Guest
 
Posts: n/a
Hello Randy I have a 92 500SEL and when I took it to the dealer he said that the seals needed to be replaced on the power steering pump. There was a slight leak but not a whole lot. Have you had any other problems with yours? What are the typical leaks on this car? I have also had rough ride in the rear when going over speed bumps. You can e-mail me direct at fberry@cinergy.com or post here on the board. Thanks
  #5  
Old 05-23-1999, 10:00 AM
Randy
Guest
 
Posts: n/a
Fred, Given your repy comments, and the others, I took my car in for repair. They did rebuild the power steering pump, saying it was "leaking between the halves." I have not had any other problems with this car, leaks or otherwise. If you have a SEL, it is not the same body as the SL, but I do not notice anything strange or out of sorts when I drive over a speed bump. Thanks for the reply.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering Leak - '92 300TE 4Matic jerseyjeff Tech Help 2 02-14-2007 07:22 PM
95 S420 Power Steering hose leak fixed. DanielW Tech Help 0 12-31-2004 02:38 AM
power steering stop leak rebenz Tech Help 6 11-17-2002 12:47 PM
Power Steering Problem - Need Advice arnelrac Tech Help 3 02-10-2002 01:05 AM
Power Steering Pump Leak 92 500 SL vkhanhn Tech Help 2 10-08-2000 09:47 PM



All times are GMT -4. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page