Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-19-2002, 11:48 PM
Rookie DIYer
Join Date: Jun 2002
Posts: 106
'96 c280 Questions for an expert

i have a '96 C280 and when i first got it, 2 months ago, i released the headrests... it worked fine... then I had the head gasket replaced and every since the headrests wont go back down by using the switch in the center console... i have also noticed that the trunk will not release with the center switch... i am assuming that this is a vacuum valve problem as i have been reading but I hear a clicking sound when i press both of these buttons so i am assuming that the vaccum valve is operational. however i still have not been able to figure this out. i am a new comer to the world of mercedes and would love to be able to fix this problem im having... i also have a random electrical problem that may or not be related to this... about once every 10 times i get in my car the auto down function on my windows don't work... the next time i restart the car everything is fine... its not a big deal but it does seem a little weird.... not to mention sometimes my rpms jump while i am sitting still in drive or reverse... if i take my foot of the brake the starts jolting forward or backward, depending whether in D or R. This also does not happen all the time but i am thinking something is up, maybe spark plugs or dirty fuel filter, or whatever... i know this is alot but i love this car and am a perfectionist... my last thing is that i once got all the windows to come down by using the remote... i havent been able to duplicate this with any of the combonations of hitting the button, anyone know what does it, or it could be screwed up due to the rest of these problems... one last thing i just remembered, i checked the fuse box in the trunk and it has ALOT of empy slots for fuses, but i couldnt find what each slot was for anywhere, checked the manual and everything... i am assuming that the paper that is usually on the fusebox lid is gone....

thanks for everyones help, this forum is the best MB one on the web, other ones take forever to respond and usually they have nothing to do with the car.

PS: where can i get my hands on a 96 C280 service CD Rom that i have read so much about on this forum... hopefully you guys can help me out, its hard to see with those damn headrests up all the time
Reply With Quote
Old 06-20-2002, 12:49 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
Yes you have a vacuum supply problem. Usually a grey plastic line is connected to the intake manifold directly. The click you hear is the electrical switch that opens the vacuum supply to the diaphrams that unlock the head rests and allow them to drop.
Reply With Quote
Old 06-20-2002, 10:26 AM
Ali Al-Chalabi's Avatar
Senior Member
Join Date: Nov 2000
Location: Knoxville, TN
Posts: 1,837
To get all the windows down at the same time:

Using the driver's door keyless entry reciever do the following:

1 Unlock the car (if it is not already unlocked)
2 Lock and hold the button for 5 seconds
3 Unlock and hold the button, the windows will come down.
Ali Al-Chalabi

2001 CLK55
1999 Dodge Ram 2500 Cummins Diesel
2002 Harley-Davidson Fatboy
Merlin Extralight w/ Campy Record
Reply With Quote
Old 06-20-2002, 02:36 PM
Rookie DIYer
Join Date: Jun 2002
Posts: 106
is my vacum problem coming from under the hood or in the trunk and do you guys know where i can get a new vacum pump or how i can do some troubleshooting to see whether it is the pump or a leak in the line... could it be that the mechanic inadvertently pulled one of the lines out when he was changing the head gasket?
Reply With Quote
Old 06-21-2002, 12:40 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
I think your leak has to be right at the intake manifold. If I recall correctly the vacuum line runs over the top of the oil filter cap. If you lightly pull on the individual lines I'm guessing you may notice that the rubber hose connection to the hard plastic line has pulled loose. I've seen this before after people visit the quicky lube joint and get the guy that was flipping burgers last week but now is a mechanic.
Good luck!
Reply With Quote
Old 06-21-2002, 01:32 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
When you roll up the windows via the remote... be sure and keep the key pointed directly at the rear view mirror, not moving it around, because the signal is easily interrupted.

I would recommend ordering a new label diagram for the fuses. And yes, it goes on the underside of the panel.

The W202 chassis CD-Rom service manual (from MB) was supposed to have been released already... so I would expect it to come out any time now.

Good luck!
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page