Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-23-2002, 10:03 PM
Posts: n/a
92 500sl trans problem

hi, my 92 500sl trans seems ill. when i shift into rev from park or drive or n it feels like it is going into rev but at the same time it seems to lock up, when you try to step on the gas the car will not move like you are power braking it. in drive it seems to shift normaly hot or cold, please help. thanks sven.
Reply With Quote
Old 06-24-2002, 01:47 PM
Registered User
Join Date: Aug 2001
Location: North NJ
Posts: 117
I've heard this can be caused by the reverse band locking up. I think there's an adjustment for modulation pressure on the trans, also, remember to check the fluid level, it plays a big part in these MB's. Otherwise, you may be looking at an overhaul. Eli.
'90 500SL (sold)
17" AMG's
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page