Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-14-2002, 02:56 PM
Registered User
Join Date: Jul 2001
Location: Boca Raton Florida
Posts: 26
Sealant question and a thank you

First off Thank you chowpit for emailing me the 300e water pump manual pages it was a awesome help !!!! thank you

Question i have do i need any sealant on the bottom water pump bolts seems like i am seeing water in the threads so i wonder if they pass through , also any sealant on the sensors that go in to the w/p housing ? i also think i need some on one of the bolts that hold the y bracket on the tensioner , from what i read , also should i look for the locktite 5900 or the hylamar sealant that i read about here

Not a bad diy job read the posts did my searching and once again this board was a valuable resource ,removed it this morning, only small problem i ran into was a rounded allen on the right side but a few taps on the socket with the hammer to seat it better did the trick , but to find a replacement bolt on a sunday seemed to be a tougher job so ill wait till tommorow at the euro parts store.

thanks again for all those who replied to my original post ,
1985 190 2.3
1993 300e 2.8
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page