Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 05-30-1999, 09:43 PM
Posts: n/a
on my 1986 420 sel the rear vents for the a/c were working fine and just as I went to switch the air in the back off the switch got hard to move and would move back to a certain position anytime I moved it.
I think it is a problem with the switch because it feels different when I try to move it. It would be very helpful if someone can give me an idea what may be wrong and how the rear vent works with the cable that looks like it goes to the front of the car.
Old 05-30-1999, 09:55 PM
MB Medic
Posts: n/a
You are correct, the cable does go forward to the heater/a.c. case to a flap control. This is not a problem that most non pro-techs would want to handle. A visit to your M.B. repair facility might be in order.

MB Medic
14 year MB tech
7 year shop foreman @ independent MB/Volvo shop
Old 05-30-1999, 11:42 PM
Posts: n/a
I am going to try for a little while to fix it. How can I tell if the cable is pulling at the front of the car??? Do those vent knobs on the dash do anything to affect the rear??
Old 05-31-1999, 09:49 PM
Posts: n/a
The vent knob at center of dash has notthing
to do with the rear vent.
the cable is from the rear vent knob to the heater box (behind the radio)
there is two air tubes run under center consol at each side to rear vent,cable is right in the cneter.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
126 Rear Wheel Bearing Bob Cavazos Tech Help 5 09-05-2006 07:58 PM
Defroster Vents Stuck Closed ?? 126 MB meltedpanda Tech Help 3 01-10-2005 01:38 PM
92 190E 2.6 - A/C blows cold through center vents, but hot through both side vents lotlizard Tech Help 10 09-20-2001 10:59 AM
Rear A/C Blowing Hot Air ChrisLiu Tech Help 6 04-24-2001 07:29 AM
Removing A/C vents in 300E pezzy Tech Help 2 01-11-2001 08:12 AM

All times are GMT -4. The time now is 12:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page