Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-20-2002, 10:12 PM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Unhappy AC Help

Looks like I'm screwed. The AC stopped working a couple of days ago. Checked the fueses and all seemed well. Checked the AC lines and the metal portions were sweating. This morning it started working agian but was making a clicking noise. A little later in the trip, I **** it off and when I started the car again, it would not work.

When the car is driving, a little outside air comes in. More as I drive faster. When I turn on the AC mode, I hear a "clunk" and no air anymore, Turn AC mode off and a little air comes in. Even in defrost mode, you get a little hot air coming out of the side vents and fresh thru the center but no rush of air,

It is my belief that Benz Bin stocks the fans but they have 2 different models. Does anyone know the difference? Also, how difficult is it to install one of these things? TIA
Reply With Quote
  #2  
Old 07-21-2002, 12:45 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Looks like you haven't a clue whats wrong. Why are you buying parts? Does Benz Bin help you diagnose? Maybe sales statistics.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 07-21-2002, 12:56 PM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
I figured that if the fan is intermittent and makes a clicking noise when it is on, the motor is shot. If the AC works and the fan doesn't, is that the correct diagnosis or is there more to it? Thanx
Reply With Quote
  #4  
Old 07-21-2002, 01:28 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
The amount of air through the vents shouldn't change whether you engage the A/C or not. I'm not sure about your klunk.

Much of the blower can be tested electrically at the three wire connection next to the brake booster. You should get a wiring diagram to see which wire does what.

The blower could easily be the problem, but its hard to get to and rather expensive. There are some easy tests and some easier answers. Be sure that all the fuses are good. There is often a single strip type fuse in a separate small box on the dricers side fender that cracks causing blower failure.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #5  
Old 07-28-2002, 02:02 PM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Talking

Fixed. All fuses were intact and everything getting power. Gillybenztech took out the motor and squirrel cages and stuck it onto the new motor I got from German Star and it works. I'm cool and happy once again
Reply With Quote
  #6  
Old 07-28-2002, 03:53 PM
Member
 
Join Date: Dec 2001
Location: your moms basement
Posts: 65
it would have helped if you had told us what type
of veh you had
__________________
fabulous!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page