Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-1999, 01:54 AM
henry
Guest
 
Posts: n/a
The doors on my 90 300E would lock by itself occasionally when I'm driving, then seconds later the alarm would be triggered and the horn would go on and off. I would have to stop by the side of the road, use the key to unlock the door to turn off the alarm.

I took the car to several mechanics, none was able to identify the cause. However, last winter the local dealer discovered a leak in my right rear light assembly, which was causing rainwater to fill up in the trunk. When they fixed the seal and dried the trunk the problem went away for several months. Recently however, the problem seems to have resurfaced, albeit infrequently. In addition, the External Lamp Failure light comes on when I shift out of Park -- as far as I can tell, all the lights are working.
  #2  
Old 06-02-1999, 12:47 PM
MB STARS
Guest
 
Posts: n/a
Your problem could come from the door lock
micro switch I have seen it go bad a lot.
cost to repair is not cheap!I will just disconnect the system to do that remove passenger side floor mat & plastic panel
remove two connectors at control unit (black)
You can have after market alarm system installed for $200-$300 with remote control.
  #3  
Old 06-02-1999, 10:24 PM
Benzmac
Guest
 
Posts: n/a
On the bulb out light, be sure to check the reverse lamps and they have to be the same wattage.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
remote entry won't arm alarm 92 300E Uncle Acky Car Audio and Multimedia 11 02-22-2008 02:38 PM
Any help with an Audi alarm?? JustinMorrison Tech Help 2 01-13-2005 08:57 PM
Alarm for 92 300E CuCullin Tech Help 6 07-08-2003 05:59 AM
How do I disconnect the alarm on my 300E? arias Tech Help 5 02-29-2000 07:13 PM
Alarm in 88 300E kombmh Tech Help 3 06-15-1999 10:28 PM



All times are GMT -4. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page