Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-02-1999, 11:19 PM
E. Lee
Posts: n/a

My 1988 300E W124 has idle speed problem...when the car is cold, idle speed (when engaged in P or N), it's about 600-700 rpm (which is normal), however, when the car is warm, the idle becomes 1500 to 2000 rpm (when engaged in P or N)!!

My MB mechanic told me that the electronics part of the "air flow volume" sensor (the thing that looks like a diaphragm underneath the air filter element) is defective, however, the actual diaphragm is fine. He told me that I must replace the whole thing (the diaphragm with the electronics part) must be replaced, since they only come together, and the electronics part is not sold separately. The whole thing will cost CDN $700!!

I figure, if the electronics part is available separately, I would save quite a bit of money. Is the "electronics" part available separately? Does anybody have the part number to it?

Thanks very much.
Old 06-02-1999, 11:40 PM
Posts: n/a
Lee !
I have to tell you SORRY the air flow sensor is only come with air flow housing you can't
buy it separately have to pay big $$$ for it
hope is help.
Old 06-03-1999, 09:01 PM
Posts: n/a
The reason that you cant buy the sensor separate is that the adjustment is very critical to emission results & most shops don't have the equiptment to test the emission output.
Old 06-03-1999, 09:59 PM
Posts: n/a
Be sure that it is not the throttle switch that is faulty! Either way the fuel distributor has to come off.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 10:25 AM
Regarding Idle speed in 300TE endeavor Performance Paddock 1 03-13-2004 09:40 PM
The idle speed, should it vary? rbort Tech Help 0 03-08-2004 11:31 PM
300 E - High Idle Speed jgl1 Tech Help 4 10-31-2000 12:15 AM
'83MB 300SD Idle Speed Wm. Lewallen Tech Help 2 04-24-2000 08:52 PM

All times are GMT -4. The time now is 05:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page