Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-1999, 11:21 PM
saltysam
Guest
 
Posts: n/a
When starting , the electric fuel pump produces a mid to high freq buzzing sound. It stops after a few moments. No other symptoms. Is this something to be concerned about?
  #2  
Old 06-04-1999, 11:27 PM
Benzmac
Guest
 
Posts: n/a
The sound probably doesn't go away, but is muffled by the cars' engine. I would have an amperage test done on it to be sure it isn't going to fail soon.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E Fuel Pump Relay/Electrial problem treynolds Tech Help 0 05-29-2003 11:59 AM
380E won't start, fuel problem (pump good) New2MBZ Tech Help 0 05-22-2003 01:06 AM
Fuel pump 1971 280SE rggball Tech Help 0 05-08-2003 11:46 PM
C280 Fuel Pump David C Klasse Tech Help 0 10-06-2001 06:36 AM
Help! Fuel Pump Relay verification barndoor Tech Help 1 08-05-2001 09:51 PM



All times are GMT -4. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page