Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-03-2002, 12:46 AM
TurboTurbine
Guest
 
Posts: n/a
springs or struts?

lately my 300D has been performing in very poorly in terms of suspension. initially i thought it might be the struts gone bad, the car does bottom out ocassionally. however it does not really bounce wildly on bumps as is the case when the struts are bad. on the other hand i can feel evety crack bump and pebble on the street coming up through the seats in side the car as sharp blows. what coud it be?? any help would be appreciated greatly.
Reply With Quote
  #2  
Old 08-03-2002, 12:58 AM
csnow's Avatar
Registered User
 
Join Date: May 2002
Location: Mass
Posts: 1,127
How many miles are on the struts?
While springs can get tired with age, it is unlikely that they would contribute to the symptoms you describe.
These symptoms are typically a sign of strut failure in my experience.
__________________
1986 300E 5-Speed 240k mi.
Reply With Quote
  #3  
Old 08-03-2002, 02:27 AM
Registered User
 
Join Date: Jan 2001
Location: oregon
Posts: 2,013
springs and or shocks..........
William Rogers......
Reply With Quote
  #4  
Old 08-03-2002, 02:23 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
TurboTurbine

The '84 300D cars do not have front struts. The shocks are separate.

Some questions for you:

-How many miles on the car?
-Does the rear sit lower than the front, unloaded?
-Depending on miles you may want to check the front suspension for:
-Worn balljoints
-Front wheel bearing adjustment
-bad tie-rod ends
-leaking shocks: a lot of oil down the sides.
-Idler arm bushings
-The steering shock (it could simply be this)

Hope this helps
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #5  
Old 08-03-2002, 06:53 PM
TurboTurbine
Guest
 
Posts: n/a
thanks for all the replies, i should have mentioned that i suspect the rear suspension, the front is OK. also i have seen too many mercedes that ride really low and typicall lean to the left when viewed from behind leading me to believe that is just the way mercedes suspension is. i will repalce the dampers and see how it works.
Thanks again.
Reply With Quote
  #6  
Old 08-03-2002, 07:05 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Miles ... how many miles?

I would guess that it sits low in the back .... if so replace the rear springs. The unload static ride height is supposed to be with the rear slightly higher than the front.
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #7  
Old 08-04-2002, 01:54 AM
Registered User
 
Join Date: Apr 2000
Location: LEMONT-CHICAGO
Posts: 412
Don't buy KYB shocks they are junk,buy Bilstiens
__________________
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote
  #8  
Old 08-04-2002, 02:27 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
JDUB is right. I had KYB shocks on an old car and I wish I had bought Bilsteins. Since then I only buy Bilsteins HDs
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #9  
Old 08-04-2002, 02:55 AM
TurboTurbine
Guest
 
Posts: n/a
""-How many miles on the car?
-Does the rear sit lower than the front, unloaded?
-Depending on miles you may want to check the front suspension for:
-Worn balljoints
-Front wheel bearing adjustment
-bad tie-rod ends
-leaking shocks: a lot of oil down the sides.
-Idler arm bushings
-The steering shock (it could simply be this) ""

-the car has roughly 312000+ miles on it.(dont know when components were changed)
-The rear does not sit much lower than the front.
-the front tie rod ends are unfortunately shot (lots of play).
-every thing is so black on the underside form a leaking muffler that it is impossible to tell oil from soot.
-also i feel all the vibration coming as though the chasis is sitting directly on the rear trailing arms.
-i am not sure if it is psychological but i could swear that she leans a little to the left.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page