Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-08-1999, 02:44 PM
hancheng
Guest
 
Posts: n/a
The tachometer sometimes doesn't come to work after the engine has been started for 30 seconds to 1 minute. Yesterday it didn't start working after I drove the car for 5 minutes. After it starts working, it works just fine. Is there any fuse or relay I should check first?

------------------
Harry (94 C280)
  #2  
Old 06-08-1999, 08:52 PM
M.B.DOC
Guest
 
Posts: n/a
Possibly the tach Needle is sticking to the stop pin. Simply tap on the top of the dash the next time it happens & see if the tach starts to register. (Benzmac shared this w/me). The glue on the pin can be cleaned by a M.B. tech, if thats the problem. No seperate relay or fuse.
  #3  
Old 06-08-1999, 11:04 PM
Benzmac
Guest
 
Posts: n/a
I have cleaned a couple and it was fixed for a while..but the problem did come back on one of them. I then cut a small black poece of hose and slid it over the pin. Fixxed!!!

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #4  
Old 06-09-1999, 02:09 PM
hancheng
Guest
 
Posts: n/a
That's really a great tip. Just simply tap on the top of the dashboard, and IT WORKS!! Thank you, M.B.DOC and Benzmac.

------------------
Harry (94 C280)
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 C280 Gas Gauge Problem aklim Tech Help 4 08-04-2003 10:05 AM
ATF Change Problem - 1994 C280 bainjs Tech Help 5 04-15-2002 08:44 PM
C280 Water Problem ! HELP! amg142 Tech Help 3 06-07-2001 03:13 PM
C280 temp problem??? amg142 Tech Help 6 05-28-2001 04:13 PM
C280 starting problem ARJAY Tech Help 2 07-01-2000 08:50 AM



All times are GMT -4. The time now is 02:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page