Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-12-2002, 01:32 AM
Registered User
Join Date: Feb 2002
Location: Seattle WA
Posts: 39
ATF in Oil

I just changed my oil in the 2.3 and 7 quarts came out! Should be about 5. All fluids except the ATF are normal levels. I have had to keep a constant check on my ATF. I seems to be losing about a quart in two weeks. No apparent leakage anywhere, so i'm suspecting a leaking vacuum modulator. Is there another way the ATF can be migrating to the engine oil?
I am also ruling out fuel in the oil, doesn't seem to be running rich, runs perfect. Stumped??
1991 190E 2.3 SOLD
1972 911t 2.4 owned since 4/80 300,000+ miles SOLD
1999 C43
Merlin XLM, All Ti, 17.5lbs.
Reply With Quote
Old 08-12-2002, 06:23 AM
engatwork's Avatar
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,244
There would have to be some funny stuff going on to get ATF back into the oil. Are you sure your car ONLY holds 5 qts? Even if the vacuum modulator were leaking I don't think it would get to the crankcase.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page