Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2002, 07:37 AM
Registered User
 
Join Date: Mar 2001
Location: Ireland
Posts: 56
1994 S320

Hi all,
Just purchased a 1994 S320 with 111,000 miles up. A number of problems exist.
1. Blower not operational on a/c. Checked fuses all ok
2. Red battery light on when driving vehicle after five minutes. Goes out comes on intermittently
3. Rear window only defrosting in sections.
4. Oil leak to front of engine

I imagine a number of you may be familiar with S320 problems so if you could let me know I would appreciate it
__________________
260pete
Reply With Quote
  #2  
Old 08-12-2002, 08:13 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
<<<1. Blower not operational on a/c. Checked fuses all ok >>>


Blower regulator is a common failure, remove the cowl cever and dust filter, blower is underneath, check for reference voltage in and blower voltage out.

<<<2. Red battery light on when driving vehicle after five minutes. Goes out comes on intermittently >>>


Check the brush pack, you'll probaly find a set of worn out brushes.

<<3. Rear window only defrosting in sections. >>


Sounds like rear glass time, however, not all of the wires are defroster grid lines.

<<4. Oil leak to front of engine >>


Front cover



Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #3  
Old 08-12-2002, 09:15 AM
Registered User
 
Join Date: Mar 2001
Location: Ireland
Posts: 56
1994 S320

joe p

I would not be as technically minded as yourself. Just to explain to me:

1. Depending on the voltage coming from this am I looking at an expensive repair.
2. You speak of the brush pack. Are you talking about the regulator.
3. I think I had this problem on previously owned W124 models.

It seems I have purchased a high cost maintenance vehicle. As I have said, if you are familar with any further problems I might encounter please let me know. Thanks for the speedy reply.
__________________
260pete
Reply With Quote
  #4  
Old 08-12-2002, 09:32 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
>>>1. Depending on the voltage coming from this am I looking at an expensive repair. >>>


The blower regulator is not cheap but, isn't too bad. Check FastLane for preices. There was a update on these to help them shake heat so dont be suprised if the replacement looks different than the orignal. You can replace this yourself with a #2 phillips and a torx driver set.


<<2. You speak of the brush pack. Are you talking about the regulator. >>

Same part, should be under $100.00 for a Bosch unit. Same deal, #2 phillips, 2 skrews.



<<<3. I think I had this problem on previously owned W124 models. >>>

Not uncommon, same part of all the benz model, different part numbers tho. Some alternator require removal of the big black plastic cover to replace the regulator but, on the 104 powered cars it can be done on the car.




Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #5  
Old 08-12-2002, 11:50 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
Adding to Joe's post..
The alt on these 104s w/front lip seal leak are susceptical to oil contamination on the brush unit due to there location.
If the alt. is saturated w/oil from the leak, this may cause your alt problem..
Reply With Quote
  #6  
Old 08-12-2002, 08:12 PM
Arthur2k
Guest
 
Posts: n/a
May I ask about the price which you had paid for this vehicle?
Reply With Quote
  #7  
Old 08-13-2002, 05:15 AM
Registered User
 
Join Date: Mar 2001
Location: Ireland
Posts: 56
1994 S320

Dollar equivalent $11,500
__________________
260pete
Reply With Quote
  #8  
Old 08-13-2002, 02:14 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Wow! Very, very, cheap price.

I checked the used car values for a car like yours with similar miles, and in Southern California, depending on overall condition, that car would sell for about $18,000.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #9  
Old 08-13-2002, 02:30 PM
Registered User
 
Join Date: Oct 1999
Posts: 1,562
Hi Paul- hope all is well on your side

just struck me that

....perhaps the pricing diferential you've discovered may be due to a less optioned Euro model S320 vs. fully optioned N America S320 version....

food for thought
best regards
-fad
Reply With Quote
  #10  
Old 08-13-2002, 02:33 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Yeah, you may be right Fad.

Hey Patkinson, what options did your car come with?

I still find it hard to believe that MB would've sold a "base model" W140, even in the UK.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #11  
Old 08-13-2002, 05:28 PM
Registered User
 
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
A few things to mention here

I think the blower is issue is the blower resistor...and that si a very common failure...as for the battery light...have you checked that all the belts are functional/operative...I used to have that problem at cold start all the time...and it was a belt

not sure about the defrost...and the oil leak sounds typical at that mileage
...and btw that was one heck of a price...and you are right the 140 is an expensive car to maintain..but a wonderful one to own and drive daily

Warren
1992 300SD 145K
Columbus Ohio
Attached Thumbnails
1994 S320-1992-300sd.jpg  
Reply With Quote
  #12  
Old 08-14-2002, 06:23 AM
Registered User
 
Join Date: Mar 2001
Location: Ireland
Posts: 56
1994 S320

Minus heated seats I think every other extra is on this including all leather interior (very unusual on this side of the Atlantic)
__________________
260pete
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page