Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-23-2002, 01:42 AM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Exclamation Weird 300E electrical glitch

Well here's the routine. With stereo on the other day, I tried to use the cigarette lighter to charge my cell phone. What resulted was a blown fuse (forgot # - controls stereo). I replaced the fuse and now when I either open up the glove box (light comes on) or try to use the cigarette lighter, my stereo, cigarette lighter or glove box light (whichever I used) AND my power windows will all not work.

No blown fuse now (first one must've been weak) but they all shut down for about 5 minutes while driving, then suddenly will come back on and work again. If I pull over and reset the ignition all is back to normal.

Anyone smell a gremlin behind my dash?

'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page