Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-22-1999, 12:03 AM
Posts: n/a
I,m Back!!!!

It has been a month, since I have been here last, nice to be back, and I see that in one month there is 200 new members, WOW!

Right to the chase.

Remember that diesel whining problem I was talking about before?

Well before signing off, I counted 5 people with this problem, they had been in to there dealers, and no-one has seemed to find out what this is.

Well, to cut to the chase, the head tech at Benz in Canada wants me to change the oil-pump. On the computer there is a new part number for it.

That being said, a new part number either means a new company is making the oil pumps since last year, or they have been modified .

Now dont get off track here, if this is or was the case, how come there is no Service Bulletin on it?

But, here is my question, on this engine, can there be a oil pressure test done while the engine is running?

I want this tested before and after the old unit is taking off, and the new one is put in.

I dont believe in just chasing after ghosts even if the warranty is going to cover it.

If this does fix the problem though, this will be a first.

Chris Ecklund

with new e-mail address!!!!!!
Old 06-22-1999, 08:47 PM
Posts: n/a
The pressures will probably be the same, but the pump is making the noise possibly. The 104 engine has a simmilar problem and Mercedes said that it was normal in the 104.


Old 06-22-1999, 08:54 PM
Posts: n/a
Does the noise happen during the first 3/4 minutes of operation? If so take to your local dealer for that special oil pump. For that is the problem.
Old 06-23-1999, 06:17 PM
Big Eck#2
Posts: n/a
Yes Sir, it happens only when cold, and accelerating or going up a hill under load.

Since I moved, I dont go up the mountain anymore with a cold engine, and the noise has gone away.

However, driving on a level road when cold, if I accelerate hard, the noise will come back.

What do you think this is?

And why?

Do you think it is the clearances are to tight?

Could the oil pressure have been effected, either to high, or to low?

The only other time I hear it, is when I take it up to 120 or higher on the highway, and it comes back ever so slightly?......

P.S.,I dont even know if my e-mail is working, but if you can let me know what it is, I will call you in Atlanta for it.(password).


Old 06-23-1999, 08:14 PM
Posts: n/a
The new oil pump is of a completely different design. Doesn't even look like the old pump. I guess the old pump wasn't the "right stuff".
Old 06-23-1999, 11:29 PM
Chris Ecklund
Posts: n/a
If this is the case, why wouldnt they issue a service bulletin about it?
Old 06-26-1999, 10:09 AM
Posts: n/a
The way legal problems are handled in the U.S. sometimes it's better not to publish the S.I. about these problems & risk class actions. Some people think lawsuits are the only way to resolve mechanical problems. So for every S.I. there are 5-6 other items that are kept internal.
Old 06-27-1999, 05:59 PM
Chris Ecklund
Posts: n/a
Well guess what?

I took it in for the new oil pump, and I looked at the new one before it was going in, without seeing the old one, I can not tell you obviously if it is different from the old one or not.

But, with the dumb blond excuse, the dealer could not duplicate the noise..........

So, I am going to leave the car there over night, then go back in the morning and show them this time.

I will also bring along some peroxide for hair bleaching...

I am actually glad they could not reproduce the sound, as I did not have a camera with me at the time. What I will do is take a picture of the new pump, and also one of the old pump.

They told me they have to pull out the engine to do this job, is this true?
Old 06-28-1999, 08:00 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
We installed several of these pumps at -------- House imports. Not once did the engine come out.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diesel exhaust... good or bad for you? JHZR2 Diesel Discussion 15 07-31-2005 09:16 AM
my diesel purge experience JHZR2 Diesel Discussion 19 07-08-2005 11:12 PM
V6 mb diesel fahrgewehr2 Diesel Discussion 16 12-19-2004 01:42 PM
Diesel Gods, Please Help --buying a diesel - long post, sorry BenzMatic Diesel Discussion 12 09-28-2004 12:27 AM
Why a Diesel? KevinM Diesel Discussion 26 12-12-2001 10:38 PM

All times are GMT -4. The time now is 09:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page