Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-22-1999, 12:33 AM
Big Eck#2
Posts: n/a
This friday when my 98300 DT goes in, they are also going to be putting in a resistor of sorts in the wiring harness.

Here is how this all came about.

When I was shopping for my next car, I looked at 2 97 diesels that had both there instrument panels replaced, with new odometers etc...

This seemed very odd dont you think?, to have 2 seperate cars on the lot with this problem?

Well my 98 has blown 2 bulbs, and the running light itself has actually got cracked somehow, so this bracket is being replaced.

My dealer has said that they are apparently showing up in the taillight assemblies, where the bulbs pop first.

Now this relay/resistor, might/could be a Canadian thing only, as the States do not have day-time running lights yet.

Unless there is some one else out there in the States whom has had this problem also.

Well just sharing for now, I will fill in the group this weekend when it has been modified

Chris Ecklund
Old 06-22-1999, 09:10 PM
Posts: n/a
The W210 chassis has had it's share of electronic inst cluster failure. This is a vender problem (VDO). BMW started having problems w/system since 1988. M.B. didn't start using this system until 1990. Seems like the idea is good but the execution isn't. AS for the lights all W210 chassis have had a high failure of exterior bulbs. There is a S.I. for modifications to the headlights & parking lights.


Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W124 Blower Problems (300E) valu8or Tech Help 15 01-29-2005 03:08 PM
1989 300E Electrical Load & Alternator Tassie Tech Help 0 01-16-2005 06:31 PM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 12:14 PM
97 E 420 Electrical Problems mmmshop Tech Help 1 07-02-2002 02:56 PM
1999 E300D Electrical Problems searaypaul Diesel Discussion 11 05-10-2002 05:52 PM

All times are GMT -4. The time now is 08:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page