Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-03-2002, 12:59 PM
jsmith's Avatar
Ronin
 
Join Date: Aug 2001
Location: At Sea
Posts: 1,729
instrument cluster & speedo cable question

i've found all the great threads on this topic but i still think i am missing something here. there is always a reference to "unhooking the speedo cable under the floor mats" to give more slack. i am not sure what this means - is there supposed to be some clip that secures the cable to the steering column? i can't find one and i can't get enough slack somehow. i've even taken the side vent out and i still can't budge the cluster out more than an inch or so.


TIA...
__________________
joE
1993 300e-2.8
- gone now <sigh>
"Do not adjust your mind, it's reality that's malfunctioning"
http://banners.wunderground.com/bann...L/Key_West.gif
Reply With Quote
  #2  
Old 09-03-2002, 03:08 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Then get under your car and...

loosen the speedo cable or give it some slack. You may even have to disconnect the cable from the transmission side.
__________________
J.H.
'86 300E
Reply With Quote
  #3  
Old 09-03-2002, 03:30 PM
jsmith's Avatar
Ronin
 
Join Date: Aug 2001
Location: At Sea
Posts: 1,729
from the footwell, i am able to push up the cable, enough to give it more than an inch of travel i think. does unhooking it from underneath mean that there was some kind of restraint that i don't have? the various descriptions indicate that it should slide out without a lot of difficulty. i got a pretty good grip on it once i had the ac vent out...
__________________
joE
1993 300e-2.8
- gone now <sigh>
"Do not adjust your mind, it's reality that's malfunctioning"
http://banners.wunderground.com/bann...L/Key_West.gif
Reply With Quote
  #4  
Old 09-03-2002, 03:51 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
You may have an custom made speedo cable or...

and aftermarket one. Again, look under your car , follow the cable and see how much slack you have. I suspect all the slack is under you vehicle. If that is the case, just push it into the cabin so you can have more slack.
__________________
J.H.
'86 300E
Reply With Quote
  #5  
Old 09-03-2002, 05:58 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Just pulled my W124 cluster a few weeks ago. The Haynes manual states that the cable should be disconnected from the transmission...I don't believe that is necessary if your cable is OEM.

There is enough cable length that you should be able to locate the cable down by the footwell and encourage maybe an inch or so of travel by pulling the slack upwards towards the gauge cluster. That should give you enough cable to be able to pull the cluster out and over a bit to gain access to say, bulbs.

Besides, the speedo lube is pretty nasty stuff, and when you start disconnecting that stuff, you run the risk of getting it on your hands, clothes, on that Palomino colored interior, etc., etc.
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #6  
Old 09-03-2002, 06:04 PM
jsmith's Avatar
Ronin
 
Join Date: Aug 2001
Location: At Sea
Posts: 1,729
g-benz,

did you use pull hooks? i started doing that and got it out maybe a half an inch. i then decided to take off the vent on the left since that was easy to do. i tugged on the exposed section but it wouldn't budge. unfortunately i ran out of time and had to push it back in. will try again in a couple of days. thanks...
__________________
joE
1993 300e-2.8
- gone now <sigh>
"Do not adjust your mind, it's reality that's malfunctioning"
http://banners.wunderground.com/bann...L/Key_West.gif
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page