Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-08-2002, 11:57 AM
Registered User
Join Date: Jul 2002
Location: North Carolina
Posts: 18
300e stall update

Read a post today reminding us to update our problems- so the 300e still stalls- its back in the dealer service for about a week now. Last I heard they changed O2 sensor. I spoke with mechanic and suggested he look at some of the things that were posted here- and noted in the vehicle history there was a valve leak but no indication of repair. He said they had a really good mechanic on it and would have found that on this review- so I can only trust.

I read this morning though a post about rough idle that occurred after an AC repair and I am still convinced that my vehicle's problems began after the AC repair. So I will call service tomorrow and insist they review "fuel cooler in suction line for AC" whatever that is.

Well I guess the good news is while my car is in the shop I'm driving a CLK230, year 2003! but I think I still prefer my 300e- oh by the way which I learned is a 92 not 93.
Reply With Quote
Old 09-27-2002, 01:50 PM
Registered User
Join Date: Jul 2002
Location: North Carolina
Posts: 18

Another update- yes these are real tears dripping on the keyboard...after my last post the 300e was on its way 'home' after having the oxygen sensor replaced. Another driver experienced the same highway speed hesitation- the car seems to turn off and then back on- and when he got off the road slowed down- STALL. So back to the shop for a crank sensor replacement. Vehicle ran like a dream- for 3 days.

Now in addition to the pause- almost like your heart stops beating for a moment then starts back up again- at 55 mph, at low speeds under 10mph tach and fuel pump needles fluctuate- when the tach drops quickly and does not recatch it stalls- but the new symptom- car accelerates on its own- foot off the gas in traffic and again when on gas around 40mph just keeps on going-if I experiment to see what happens it continues to accelerate to about 55 then lugs and it feels like there is a parachute or something open holding the car back.

I have mentioned to service OVP, fuel relay wiring that have been posted answers but we've replaced cylinder head (back when oil in the coolant, wondering if this did some irreperable damage) MAS, O2 sensor and crank sensor. I am definitely afraid to drive this car- so what do you think- give up?
Reply With Quote
Old 09-27-2002, 02:38 PM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Is the coil ok? check the mas relay as well.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote
Old 09-30-2002, 03:14 PM
csnow's Avatar
Registered User
Join Date: May 2002
Location: Mass
Posts: 1,127
Have you considered a fuel problem?

The stalling could be the fuel pump itself, or a clogged filter.
The surging may point towards the fuel pressure regulator.
1986 300E 5-Speed 240k mi.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page