Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-30-2002, 11:16 AM
Registered User
 
Join Date: Sep 2002
Location: New York
Posts: 12
Question 98 e320 Transmission question?

Is it common for the Ď98í e320 to downshift hard when slowing down or braking, I've notice my car seems to jerk when Iím slowing down or braking. I had Mercedes check the motor mounts and I was told that they were fine. Iíve also notice that when creeping at slow speed, if I come off the gas, the car doesn't glide but the speed drastically drops. I have a starmark warranty until 2/03 and if this isnít common for the Ď98í e320 I will have the dealer check the tranny out. If I take the car in and if they donít find a problem will I be charged for diagnostic or will the starmark warranty cover the visit? If anyone can help answer my question I would be most thankful.
Reply With Quote
  #2  
Old 09-30-2002, 11:53 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
It's normal to feel the 722.6 tranny downshifting, but not abruptly. Search JCE's posts, as he has a 1998 C230 with all sorts of tranny woes, including the problem you mentioned.

A friend of mine with a 98 C280 had such violent downshifts that it nearly locked up the rear wheels! The dealer simply installed a new transmission, and the problem was solved.

With your car under warranty, there should be NO charge for diagnostic time if the problem is with a warranty component.

I wonder is the torque converter lock-up is malfunctioning? Anyone got any ideas of why this would happen?
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #3  
Old 09-30-2002, 11:54 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
I remember Kevin said his C280 did it lots worse when the tranny temp would be hot, like during hot weather, stop and go driving etc. Is this the same for you?
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #4  
Old 09-30-2002, 12:33 PM
Registered User
 
Join Date: Sep 2002
Location: New York
Posts: 12
Thanks for the information 'blackmercedes' I'll look through the post that Kevin put up. In my case unlike Kevin's c280 this happens all the time, I could just start up or I could be in stop and go traffic or on a extended trip and it still happens.
Reply With Quote
  #5  
Old 09-30-2002, 04:16 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Ooops!

You won't find Kevin's posts here, as he's not a member, but a "real world" friend of mine.

JCE is John (another one) with a 1998 C230. Search his posts...
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #6  
Old 09-30-2002, 10:55 PM
Ali Al-Chalabi's Avatar
Senior Member
 
Join Date: Nov 2000
Location: Knoxville, TN
Posts: 1,837
I have the same thing on the 4-3 downshift. It seems when braking that the downshift sometimes occurs a little late and then it bangs hard. It has been doing this for a while, with no warranty on the car now. It functions perfectly fine otherwise, so I not worried on my car. But your car has a warranty. The downshift will be noticeable, but if it is really hard, then I might want to see what the dealer says.
__________________
Ali Al-Chalabi

2001 CLK55
1999 Dodge Ram 2500 Cummins Diesel
2002 Harley-Davidson Fatboy
Merlin Extralight w/ Campy Record
Reply With Quote
  #7  
Old 10-01-2002, 12:41 PM
Registered User
 
Join Date: Sep 2002
Location: New York
Posts: 12
Thanks for the comments. I made an appointment with the dealer and I hope they find the problem and fix it this time.
Reply With Quote
  #8  
Old 10-02-2002, 01:19 PM
JetForeman
Guest
 
Posts: n/a
My 95 E320 did the same thing, harsh to obnoxious 4-3 downshift. It did it when I was slowing down to make a turn, say around 25mph, depress the throttle and bang, into 3rd we go. I was able to soften it up a lot by shortening the bowden cable more than spec.

Dale
Reply With Quote
  #9  
Old 10-02-2002, 01:36 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
.6 d-shift complaints.


freewheel units are "missing" the load then grabbing.


If you get someone who knows these units, the freewheels are a simple install, otherwise the unit will most likely be replaced. There a several valve body and .6 control unit updates as well.


Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page