Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-08-2002, 12:14 PM
Registered User
Join Date: Jan 2001
Location: Charleston, SC
Posts: 93
Climate control function

Just had the evaporator and all the vac. elements changed out on the 88 TE. Having lived with an improperly functioning climate control system for years, I have a few questions concerning the proper auto climate functions:

Is it typical to have a small continous amount of air blowing out of the defrost vents while the a/c button is pushed (defrost actuator is new)? I still get a small amout of fogging on the outside of the windshield on a humid day. Could this be a adjustment I could make by removing the glove box or is this small amount of constant defrost designed into the system?

I do not notice any change in air flow when the re-circulate button is pushed (red light on) nor do I hear any flap closing/opening (new reirc actuator). On my Saab there is a distinct increase in the airflow with the recirc. on.

After the car cools down close to the set temp. the air blows from the side vents and stops blowing from the center vents. Is this correct?

Thanks in advance

Ed C.
Reply With Quote
Old 10-08-2002, 11:35 PM
420benz's Avatar
Registered User
Join Date: Jul 2001
Posts: 951
I am having the same problem,does any one have an answer?
Reply With Quote
Old 10-09-2002, 01:46 PM
Registered User
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
fogging on the outside?! must be really cold air from the vent!
Reply With Quote
Old 10-09-2002, 02:50 PM
420benz's Avatar
Registered User
Join Date: Jul 2001
Posts: 951
Yes i think we know that, but why is a small amount of air coming out of the defrost vent?
Reply With Quote
Old 10-09-2002, 05:23 PM
dpetryk's Avatar
Electrons can do anything
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
A small amount of airflow from the defrost vents is normal. I also get outside condensation on the windshield. That is normal especially in humid enviroments like we have here. My 300e will close the center vents when it reaches the set temp but my 420's do not. I know I have one bad actuator in the 300e which I have teken out of the vacuum circuit and that might be why it does that. I suspect that a normal system would not close the center vents.
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page