Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-21-2002, 12:21 AM
rdanz's Avatar
Registered User
 
Join Date: Sep 2002
Posts: 1,158
Help Needed

94 S 350
At 600 rpm car idles fine. At 1000 rpm shakes and stumbles feels like a miss. At 1200 engine smooths out no stumble. car got 26-28 mpg now falling 20-22 also alot of blue smoke when cold gone after warm up. ? What mite this be? Where do I start?
Reply With Quote
  #2  
Old 10-21-2002, 02:26 AM
Registered User
 
Join Date: Jul 2002
Location: Dallas
Posts: 330
Give us more info. What has been done to the car service wise? What is your mileage on the car? Are you keeoing up with routine service? Is the car new to you? etc...

Bet it's someting simple like an O2 sensor.
Reply With Quote
  #3  
Old 10-21-2002, 10:16 AM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
And S350 - that's a diesel remember
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page