Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-28-2002, 11:25 AM
Posts: n/a
Question Want Get Hot

I Have a 1989 300 se.i replaced the radiator back in the summer because it was running hot.this stop that but now the heater just blows cold air when moving.If i start it and dont move it gets hot but when i go down the road it turns cold.i asked a friend about this and he said i may have knock off a vacuum you know where i can get a diagram of the vacuum Or anything you may think of.Thank You
Reply With Quote
Old 10-28-2002, 01:07 PM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
sounds like the aux water pump or t-stat to me.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote
Old 10-28-2002, 07:17 PM
Registered User
Join Date: Apr 2000
Posts: 412
Sounds to me like your thermostat is stuck open. It is a quick and easy do it yourself repair. Does you guage on the dash read 80 to 90 degrees? If it does then it could be in the climate control system.
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page