Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-03-1999, 02:55 PM
Mahesh Patel
Guest
 
Posts: n/a
Steering has almost no power assitance when turning left and some power assistance when turning right. I have replaced the power steering pump (as per my mechanics recommendation), however the problem remains. I have put part synthetic dexron III ATF. Front shocks need replacement (can this be the problem ?). It is a '87 2.3-16V with 66K miles. Any help is appreciated.
  #2  
Old 08-03-1999, 06:21 PM
Senior Member
 
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
There is spring inside power steering gear box broken............but the spring is not available from MB dealers I have no ideal where can find one......may be BENZMAC will
help you.......sorry.


------------------
MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
  #3  
Old 08-03-1999, 09:18 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The only thing I can offer is POSSIBLY a new or rebuilt unit. I don't know of many spare parts for the sectors.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #4  
Old 08-28-1999, 12:05 AM
Mahesh Patel
Guest
 
Posts: n/a
Thanks all. The problem was fixed after replacing the power steering gear.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.3 16V Ignition tumbler problem mnoll4060 Tech Help 8 11-23-2004 11:49 PM
280SE 4.5 power steering problem!!!! MercedesDude Tech Help 6 06-20-2004 07:02 PM
2.3 8V air flow sensor work in a 16v daveCT Tech Help 1 02-19-2003 11:57 AM
1986 190e 2.3 16v Cosworth transplant paulwf Tech Help 4 05-29-2001 07:04 AM
'86 190E 2.3 16V idle problem Rick Schwartz Tech Help 1 05-12-2001 10:12 AM



All times are GMT -4. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page