Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-07-2002, 02:23 PM
Posts: n/a
Question 99 C230 Kompressor Noise

I have been experiencing a noise which I describe as a "diesel knock" even though the car is not diesel. When slightly accelerating the noise begans, goes away at a slightly higher speed and returns at very low speed. Twice I have taken the car to the dealership for inspection and both times they tell me this noise is just the way a kompressor is. They tell me I will hear the rattling, clunking noise when the kompressor clutch engages and disengages.

Has anyone had the same experience and is there anything that can be done about this?

I appreciate your time and feedback.
Reply With Quote
Old 11-07-2002, 05:10 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The drive belt tensioners on the M111 engine has been a problem since 1996, the latest tensioner requires ADDING a belt shock absorber to dampen the noise (knock).
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 11-08-2002, 01:42 AM
Posts: n/a
Thank you for your reply. Do you know anywhere on the web, or anywhere for that matter, that I can read about this? I would like to educate myself before talking to the dealership service advisor again.
Reply With Quote
Old 11-12-2002, 12:07 PM
Registered User
Join Date: Dec 2000
Posts: 44
clunking noise

Do you also hear the noise if you do braking from a high RPM?? I don't know if this noise is related to komprssor disengage or not, but I test drove a komprssor the other day and it had the same noise. The other problem has bothered me is the startup. Seems that superunlead feul will cause problems and once I switch to 89 octane feul, it will be fine.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page