Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-1999, 04:46 AM
H20mobius
Guest
 
Posts: n/a
My 1984 190E 2.3 5speed with 80k recently started making a weird noise spontaneously. Sometimes when I bring the RPM's <3500-4500> up higher, a strange "blower" noise kicks on. A slight whine is noticeable as well as a loss of power. The car will then remain like this for a period, then return, only to happen later. I describe the noise as though it sounds like a blower kicks on...almost like its the auxilary electric fan or something. Could it be a belt?? Adrian mentioned something about a timing chain tensioner that has been updated 3 times or something around $1200??, could this be related? any ideas?

Chris
H20mobius@aol.com

Also, is there a lightened flyhweel clutch available for this car? Can i use a 16v pressure plate like VW's?
  #2  
Old 08-17-1999, 10:23 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
In hot weather, with the AC on the engine fan will come on with the aux fan to cool off the radiator and the condensor. This is normal and should not happen on the highway. IF it does look for bugs clogging up the fins of the condensor and or the radiator.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 08-18-1999, 02:16 AM
H20mobius
Guest
 
Posts: n/a
Not to sound like I am second-judging your response, but I may have been unclear in describing the problem. It occurs irregardless of temp and my aux fan seems to operate normally. This noise is different than that of the aux fan. It could better be described as you're driving along and rev in to higher RPM's reaching around 4000 then as though someone was to massively restrict pressure in the exhaust or something. It almost has a hummm as well as air-noise... Or it sounds like an additional belt is kicking on, but it is not. Sadly my a/c is not working at the moment, nor has it for the past year...but this noise is new. Any ideas? sorry if i'm unclear, just difficult to describe. Thanx a lot...chris..
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Road Noise in '93 190E 3.2 ejsharp Tech Help 7 12-11-2004 02:26 PM
Transmission Clunk Noise 190E 84 Benz84 Tech Help 3 04-29-2003 03:27 AM
190E tapping noise resolved! ScottyC190E Tech Help 9 04-01-2003 03:40 AM
Knocking noise in 84 190E Benz84 Tech Help 0 10-25-2002 10:54 PM
help with 190e popping noise Moab_dan Tech Help 5 04-17-2002 12:27 AM



All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page