Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-10-2002, 07:45 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Completely dead

I posted earlier that I was having trouble with the battery on my ML.

Well, my 300E is also completely dead. I drove it all afternoon to attend meetings at client sites, and it ran fine. I got home around 3:00 p.m., checked my e-mail and got ready to pick my wife up from work since the ML is dead in the garage. It was around 4:15. Put the key in and turned. Nothing! Absolutely nothing! No interior light, no lights on the dash. What happened? I cannot begin to even know where to look. Now I have two dead cars and fortunately the SL runs. Please tell me what is wrong with the 87 300E. Does that mean the car is completely dead and ready for the junk yard?

Car has close to 300K on the clock. Any help will be appreciated.

MB Roadside Assistance was called and the guy told me he will bring me a new battery for the ML later this evening. But I don't think he can figure what is wrong with the W124. I will ask him to have a look at it and hope for the best.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #2  
Old 12-10-2002, 09:29 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Nothing?

Check the battery grounds and the battery itself with a voltmeter.
__________________
J.H.
'86 300E
Reply With Quote
  #3  
Old 12-10-2002, 09:33 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
I tried that too.

I checked to make sure none of the battery terminals were loose. I would imagine if it was the fuel pump relay, ther interior lights should come on when the door was opened. It appears that no juice whatsoever is go through.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #4  
Old 12-10-2002, 10:31 PM
Jackd
Guest
 
Posts: n/a
No lights, no juice anywhere, I would not think anything but BATTERY, battery cables, body/engine grounds.
Check the battery with a voltmeeter. You should read something there. if not, you need a new battery.
jackD
Reply With Quote
  #5  
Old 12-10-2002, 11:47 PM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Yes, it was the cable. The road side assistance guy tried to jump the car and immediately knew the cable was loose. He tightened it and the car came to live. YA!!!

Thanks guys for so much quick suggestions.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page