Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-16-2002, 12:06 AM
Posts: n/a
Clutch problems!

I have just fitted a new clutch to 1972 MB 250 but have a problem with settings/clearances as difficult to get into gear?
especially reverse.
Does anyone have any data on procedure or the little idiocincracies/secrets for this operation.

Any suggestions would be welcome!

Reply With Quote
Old 12-16-2002, 02:17 AM
Registered User
Join Date: Jan 2001
Location: Los Angeles CA
Posts: 139
I doubt that there are many secrets to your particular clutch. When you had the transmission out, did you check if the pilot bearing turned freely? Also, are the hydraulics working OK? Does the clutch fork have enough travel when the pedal is depressed? I'm also assuming that you checked that the clutch fork or operating lever was not bent, and the flywheel had no high spots or burn marks.
Reply With Quote
Old 12-16-2002, 04:07 AM
Posts: n/a
Thanks HarryM,

Will double check those items!

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page