Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-16-2002, 08:27 PM
hitch02's Avatar
Registered User
Join Date: Dec 2001
Location: Fairfax, VA
Posts: 159
New (to me) W124 Coupe ??'s

Folks -

Car is a 1990 300CE with 127,xxx on it. In recent (last 20K) history, a/c was revamped, radiator was replaced, and it had a complete head job.

Overall, I like the car, but there are a few issues that you all probably know the answers to off the cuff:

1 - Recirc button - doesn't appear to do *anything*.. Push it, no vacuum noise, no light comes on.

2 - When cold, it takes several cranks to start the engine. Once running it is fine. Only thing I could come-up with that might be related was a fairly significant buzzing noise from the main fuel pump.

3 - Knocking noise from passenger front when driving at low speed - guessing ball joint, but other common causes?

4 - Passenger head rest doesn't - as I understand many of them don't. I know the motor is doing something, but the other thing is I can adjust it manually with little effort.

5 - Trip Odometer - Doesn't. Isn't this supposed to be a relatively easy fix?

Thanks for the help.

'90 300CE
'84 300D-T
'70 BMW 2800
Reply With Quote
Old 12-16-2002, 09:18 PM
Registered User
Join Date: Sep 2002
Location: Ewa Beach, Hawaii
Posts: 333
my 2 cents

Definitely get it checked by a Mercedes specialist. Spend the extra cash for a professional non-bias opinion. Then use that to bargain with the seller (maybe you could get him to lower the cost of the car by 1/2 what it would cost you to get the minor things fixed).

I bought my Mercedes with a "few" problems that I felt were fairly easy to fix, but after having the car only a year, I've already put in an additional $3000 into the car.

Don't get me wrong I love my car, but there are a lot of "small" things not working that irritate the **** out of me. I'm also too stuborn to over pay for a minor problem (ie, $200 to fix the odometer).

Anyway goodluck.
1986 Gold 300E 4Dr automatic
Reply With Quote
Old 12-17-2002, 12:52 AM
Posts: n/a

Just checking but is the climate control system on when you push the recirc button?
Reply With Quote
Old 12-17-2002, 01:16 AM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Replace that switch! $21 at dealer... I think WorldPac is out of stock on these.

Remove the 2 screws at base of wood AC panel .. just above stereo. Then remove the ACC push button control unit by removing 6 screws (2 large, 4 small). Pull the unit out and then you'll have access to switch.

Good luck!
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
Old 12-17-2002, 01:37 AM
Registered User
Join Date: Aug 2002
Location: So Cal, Beach
Posts: 250
Just to start: Cranking up to 4 seconds before start is normal.

Just read your Owners Manual, and you will be OK.
280SE 4.5
Sandals (size 11)
Reply With Quote
Old 12-17-2002, 07:49 AM
hitch02's Avatar
Registered User
Join Date: Dec 2001
Location: Fairfax, VA
Posts: 159
Thanks for the replies. As much as I'd love to use some of this stuff to negotiate the price, I already own the car...! That said, I got a *very fair* price on it, especially considering the mechanical work that went in to it.

Answering your question, yes, the climate control was on when I tried to use the recirc button. But now I'm wondering, after driving it a little more, and doing a further search on the topic, could this be related to vacuum pods? I ask only because I noticed that no air was flowing from the center vents when I had either the cold air or the warm air on, in any of the a/c settings...

Thanks again for your help!

'90 300CE
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page