Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-01-2003, 02:59 PM
W202 AMG
 
Join Date: Dec 2001
Location: Cocoa, FL
Posts: 67
Angry W202 sunroof & windows will not close

I just got my car back from the bodyshop and I thought I was having a good new year until. My sunroof will open 2 inches then stop then half way and stop the opens all the way but will not close. Also my windows roll down but ONE touch is not working and they wont roll back up. Further my car will not redline it only will go to 5000rpm and stutters.

Please help me as to what these problems might be

Regards, Christopher
__________________
'98 C280 White on Tan

-=Santa Bring me a C43=-
Reply With Quote
  #2  
Old 01-01-2003, 03:53 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
time to resync everyone



press and hold the up portion of the window switch for about 10 sec, then run the glass down, press and hold for about 10 seconds, I do this a couple of times, repeat for all 4 windows. (unless its a 02, then the SDS needs to "unsync" the dcms)

run the sunroof fully open 2" at a time then press the switch for "vent posistion", it should run all the way to vent, then work normally. Make sure when you run it all the way back you get the double click sound before moving to vent. (dunno why they do that but, that when it finds the end of the track)



Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #3  
Old 01-01-2003, 04:24 PM
W202 AMG
 
Join Date: Dec 2001
Location: Cocoa, FL
Posts: 67
Thanks you very much, that fixed it. Now I need to find out why my war will not rev past 5000rpm. When it hits 5k it looses power and has no acceleration, I can get it to hit 6000 but there is no power and it sounds like it is really struggling.
__________________
'98 C280 White on Tan

-=Santa Bring me a C43=-
Reply With Quote
  #4  
Old 01-01-2003, 04:25 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
that sounds like a air flow meter, does it surge a bit under normal accel as well as backfire when jumped on cold?


Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #5  
Old 01-01-2003, 07:24 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
My Dad's C230 (M111 engine) did the same thing. Swapped the plugs, as they had been in there since new, and it solved the problem right away.

Your M112 engine has twelve plugs rated for 160,000 kilometers, but they don't really last that long. Have they been replced lately?

Joe's comments about M112 MAS's are a good place to look too. Lots of M112 equipped cars need new ones.

Is the car lighting the CE warning lamp? If so, codes will quickly tell you what's going on...
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #6  
Old 01-01-2003, 08:36 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
What about the engine Air Filter? Or maybe fuel filter?
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #7  
Old 01-02-2003, 12:00 AM
W202 AMG
 
Join Date: Dec 2001
Location: Cocoa, FL
Posts: 67
The odd thing is I have no CE light on. It also surges slightly when cold and gets worse as the RPMs go up. My plugs might be a problem as they do have 89k miles on them. The fuel and air filters are almost brand new that that cant be it. I am starting the think the MAF could have gotten dirty because the became detatched in the wreck I had.
__________________
'98 C280 White on Tan

-=Santa Bring me a C43=-
Reply With Quote
  #8  
Old 01-02-2003, 12:53 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
Quote:
Originally posted by Wizo
It also surges slightly when cold and gets worse as the RPMs go up. My plugs might be a problem as they do have 89k miles on them.
The surging sound like a MAS. 89,000 miles means time for new plugs. Try that first, as it's cheap.

Funny that your CE light isn't on.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #9  
Old 01-03-2003, 12:57 PM
W202 AMG
 
Join Date: Dec 2001
Location: Cocoa, FL
Posts: 67
I went down to Ron's European not to far from me and we hooked my car up to the diagnostic tool and the MAF is good and so is everything else.

I am going to change the plugs and go from there. When I test drove it again I put it in neutral to redline it and it went all the way up w/ no problem but as soon as I put load on the motor it doesn't want to go anywhere. I am starting to wonder if it could be the Tranny but I sure hope not.

Thanks for the help,
Christopher
__________________
'98 C280 White on Tan

-=Santa Bring me a C43=-
Reply With Quote
  #10  
Old 01-03-2003, 03:36 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
In Neutral or Park, the engine should only rev to 4,000 RPM and the rev limiter should kick in... not letting it go over 4,000 RPM.

HTH!
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #11  
Old 01-03-2003, 03:48 PM
W202 AMG
 
Join Date: Dec 2001
Location: Cocoa, FL
Posts: 67
Quote:
Originally posted by David C Klasse
In Neutral or Park, the engine should only rev to 4,000 RPM and the rev limiter should kick in... not letting it go over 4,000 RPM.

HTH!
That is true when you are not moving. If you coast down the road and shift into Neutral then it will free rev to 6000rpm.
__________________
'98 C280 White on Tan

-=Santa Bring me a C43=-
Reply With Quote
  #12  
Old 01-03-2003, 03:53 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Yes, true. Ok, just checking.
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page