Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-03-2003, 09:33 PM
Registered User
Join Date: Jul 1999
Location: Youngstown, OH
Posts: 150
Rear end goes THWANG!!

My wife was backing out of the garage about 3 weeks ago and heard a loud "thawng" like a spring popped! The ride height is normal but, occasionally, when making a slow, tight right turn the right-rear makes the same sound. It's worse over speedbumps or dips. The mechanic stared at me like I had a third eye after he "could not duplicate" the problem.

I guess I'll wait until the problem gets worse. Anyone ever experiance this?

BTW, it's a 1998 E320T (wagon) with about 72,000 miles. It's always had a somewhat harsh ride (like it's oversprung or underdamped or both if that helps).

Reply With Quote
Old 01-03-2003, 09:40 PM
Registered User
Join Date: Aug 2001
Location: secret
Posts: 3,044
I apologise in advance for this...

You're not missing any pets, small children or tricycles are you???
Reply With Quote
Old 01-03-2003, 11:28 PM
Holson Adi's Avatar
Registered User
Join Date: Jul 2001
Location: Boston, MA
Posts: 2,561
Check this out...

My mechanic couldn't figure it out either...
2008 BMW 335i Coupe
Reply With Quote
Old 01-04-2003, 04:33 PM
Registered User
Join Date: Jul 2000
Posts: 638
rear end 'thwang?

Well, it may be a loose hub on that side. I had one that started that own it's own. Had to replace the 'spring washer' under the axle hub bolt. Cured it.

OR it cound be a CV joint on that side is dry and full of junk from a split boot. Or it cound be the hub bearing.
Reply With Quote
Old 01-05-2003, 04:12 PM
Registered User
Join Date: Dec 2002
Posts: 5
I had the same sympton on my c280- what it turned out to be was a plastic link for the rear suspension had broken and when going around corners it scrapped the inside of the the rim. You may have to get up under the rear to see it- I had to put it up on ramps.. Hope that helps
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page