Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-24-1999, 10:08 AM
mikeb
Guest
 
Posts: n/a
My MB 380SE won't start. The battery seems ok. Headlights work, radio, AC etc... fine. When I turn the key there is coplete silence. No solenoid click nothing. The ligts will not dim either. Any suggestions?
Thank you very much
  #2  
Old 09-24-1999, 10:20 AM
Turbo
Guest
 
Posts: n/a
Try to put the car into neutral and try to start it then. If it starts, the neutral-safety switch is defective. Another possibility is the ignition switch behind the key tumbler.
good luck
Turbo herb
  #3  
Old 09-24-1999, 12:15 PM
Rick Miley's Avatar
Spark Free
 
Join Date: Jun 1999
Location: Tampa, FL
Posts: 3,086
I just went through that on the 190. It was the neutral safety switch. By the way, it didn't start in neutral either. It took my mechanic 3 hours to find it, which seems like much too long. Hopefully, you won't have the same experience now that you know where to start.

------------------
Rick Miley
Tampa, FL
99 E300DT
86 190E
87 300E

  #4  
Old 09-24-1999, 07:27 PM
mikeb
Guest
 
Posts: n/a
Well, it turned out (according to my mechanic) to be a starter. Now it is working fine but of course I had to tow the car to the service.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
car won't start jude Tech Help 5 06-03-2004 12:24 PM
Sequence to start a M104 atamians Tech Help 1 01-17-2003 05:26 PM
260E has sparks but will not start saumil Tech Help 3 08-17-2001 03:29 PM
126 wont start '85 380se barndoor Vintage Mercedes 3 08-17-2001 12:37 AM
1991 420SEL - beginning of a cold start problem DieselGuy Tech Help 1 07-30-2001 04:56 AM



All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page