Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2003, 11:25 AM
1994C220's Avatar
Registered User
 
Join Date: Aug 2001
Location: Iowa City, Iowa
Posts: 124
w140 A/C problems- 1994 S320

Hi...well, I finally got the blower regulator changed out...and my heater is working great now...but, my AC is completely shot. The climate control only works in EC mode. I ran the diagnostic tests from K6JRF's page...and This is what I got for error codes:

EO 13 and EO 91

According to the site EO 13 is the connection to rear climate control module.

and EO 91 is the A/C compressor ground activation. When I clear out the codes and try to turn on the AC...the compressor clicks on for about a second, and there is a horrible screeching noise that comes from the belts around it...and then I guess it disengages itself and i get the EO 91 code again. The AC will stay in regular mode, but you can tell that the compressor is not turning on...until you clear the code, and the same thing happens again.

What I would like to know is how do I fix both of these problems? Or what do I need to check? Please give me specifics as possible, I am not to mechanically inclined, but with the right help, I have already been able to do the blower regulator in this car and I replaced the window switch console in my wifes ML yesterday.

I ran operational check too...Here are the #'s and values:
1-85, 2-72, 3-98, 4-87, 5-76, 6-99, 7-2, 8-18, 9-30, 16-0


Thanks in advance for your help...
__________________
1994 S320
131K miles

1998 ML 320
126K miles

1994 Blue C220
122K miles

Im going to Grad School @ the University of Iowa
Go Hawkeyes!!!
Reply With Quote
  #2  
Old 01-06-2003, 12:36 PM
Registered User
 
Join Date: Oct 2001
Location: Vienna, WV
Posts: 121
Sounds like your compressor is seized. You'll have to replace it.
__________________
Tom Savage
Vienna, WV
1984 300D Euro
1995 S320
Reply With Quote
  #3  
Old 01-06-2003, 12:37 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
Sorry to read that!

From what you said, it appears that the compressor is seized! If that's the only thing wrong, no big deal. So good luck!
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #4  
Old 01-07-2003, 10:14 AM
1994C220's Avatar
Registered User
 
Join Date: Aug 2001
Location: Iowa City, Iowa
Posts: 124
Thanks for the info...

Ok, hopefully it is just the compressor. Is this expensive? I know that I saw it listed on a dealer site somewhere for 800.00, but Im sure its available through fastlane cheaper...the blower regulator I just bought and replaced lists at the dealer for almost 400..but I found it for 135.00.

Another question is, can i do this job myself? or is it too tricky to risk messing up other components? And if it is too time consuming, can a good independent shop do it? How many hours of labor would it cost?

Thanks for the help
__________________
1994 S320
131K miles

1998 ML 320
126K miles

1994 Blue C220
122K miles

Im going to Grad School @ the University of Iowa
Go Hawkeyes!!!
Reply With Quote
  #5  
Old 01-07-2003, 12:38 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
If the compressor is seized and . . .

that's the only thing wrong, which is a bad assumption, then you still need to evacute the complete system to ensure it's clean and dry before you refill it!

I said it's a bad assumption because there are probably many other components bad. The receiver-dryer is most likely bad too.

So bottom line, as many other more qualified people on the site have recommended, have it done by a indy shop.

BTW, do a search to uncover some good A/C tips.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #6  
Old 01-07-2003, 06:26 PM
1994C220's Avatar
Registered User
 
Join Date: Aug 2001
Location: Iowa City, Iowa
Posts: 124
thanks...I guess Ill have to start saving up some money before the TX summer hits...

Other than the AC, and a terrible driver's side seatbelt problem, however...I have been extremely happy with my S class....
__________________
1994 S320
131K miles

1998 ML 320
126K miles

1994 Blue C220
122K miles

Im going to Grad School @ the University of Iowa
Go Hawkeyes!!!
Reply With Quote
  #7  
Old 05-24-2003, 03:17 AM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
Well, the same thing. .

happened to my a/c compressor but for a different reason.

Read this thread if you haven't already: http://www.peachparts.com/shopforum/showthread.php?threadid=65697

It seized also: would start for a second, then stop. Initially thought it was the clutch but no such luck. Did most of the 'work' myself so that kept the cost down but once it seizes, you need to flush and replace major components.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page