Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-12-2003, 11:37 AM
Registered User
Join Date: May 2002
Location: USA
Posts: 1,055
94 e320 battery issue..maybe?


Last week our 94 e320 had to be jumped a couple of times. After the second time I had my wife go to the local service station and test the battery. They took a look at it and said the water was very low..couldn't suck any out for a test. They filled it back up and said we may need a new battery but was unsure because he couldn't properly test it with the water so low at this point. He suggested charging it overnight with the new water addition and seeing what happens. He jumps the car and she drives home. I didn't get a chance to charge and it was fine like that for about 3 days.

Yesterday the car is dead again. I tried jumping it and no start. I even pulled a battery from one of my Miata (half size of benz) and no cranking, nothing. I took the battery to NAPA, left it overnight for a good charge and they report it is now fully charged. Can I expect it to hold after a good solid recharge?


94 e320 74,000 miles, battery looks fairly new but unsure of age because the top month/year sheet is not punched is an Interstate battery I can post battery specs later after I pick it up from NAPA.

If I do need a new battery, any suggestions?
Reply With Quote
Old 01-12-2003, 03:30 PM
94 E320
Join Date: Jun 2001
Location: Fairfax, VA
Posts: 437
i don't know if its the battery or not but u can't base the strength of a battery based on looks

the location of the battery is designed very well that it won't ever get dirty

i had the same thing happen to me @ 90K, it was the battery in my case and got a new one for like $100

good luck to you
Reply With Quote
Old 01-13-2003, 11:08 PM
Posts: n/a
battery problem

I have a 94 E-320 and experienced the same problem several months ago. I've over looked checking the water level in the battery since I got the car. (many years. I thought it was a maintenance free battery and in the end it was.........)

I tried starting the car one day in my garage and noticed a slight hesitation when starting and so kept trying, to push its limit, and it died after the third try.

Check the water level and several cell were dry or low. Filled and charged for 24 hrs. on trickel charge. Started right up but after about 6-8 hours went back and dead again.

If the water level gets to low the cell plates ground out and the battery can't recover. I replaced the battery and no problem.

If the charging system is working and the belt is tight I conclude it's the battery.
Reply With Quote
Old 01-13-2003, 11:32 PM
Dcraig's Avatar
Registered User
Join Date: Sep 2001
Location: So. CA. USA
Posts: 697
I think I'm having the same problem with my '94 E420. Hesitation when starting, but then again, my car sits for several weeks without being started.

Should I spring for the MB battery, or will a DieHard do?

1994 E420, Pearl Black/Black. 2.82 rear diff., AMG front spoiler, painted lower half. SOLD

1972 & 1974 BMW 2002tii's.
Reply With Quote
Old 01-14-2003, 05:30 AM
Registered User
Join Date: Jan 2002
Location: England
Posts: 1,841
You're presumably using de-ionized water or whatever the stuff you're supposed to use is?
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
Reply With Quote
Old 01-14-2003, 08:45 AM
Registered User
Join Date: May 2002
Location: USA
Posts: 1,055
I opted to replace the current Interstate MB 88 battery with 740/900 amp specs with the same (big freakin' battery). Cost was $104.00 out the door. From now on I'll be checking the water on a regular schedule. Seems to be just fine but I just installed it last night in the parking lot of my wifes workplace. It was recharged Sat night at Napa, I put in back in on Sunday, started fine Monday 8:30am but was dead by Monday 3pm.

I guess it just never recovered from the low water
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page