Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2003, 04:21 PM
fritzthetiger
Guest
 
Posts: n/a
Unhappy Squealing in Rear of 6.9

I have a terrible squeal in the rear of my 6.9, even when it barely moves. I'm not sure if it's the bearings or the brakes. The wheel hub gets very warm. Is there an easy way to asses?
Reply With Quote
  #2  
Old 01-14-2003, 06:50 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
IF the brake pads OR parking brake shoes drag you will get noise & heat build-up in the rear.
Try jacking up one side or the other & see if there is excessive drag.
If your limited slip is still good you might have to jack-up one side & use a jack stand then jack up the other side to test.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 01-14-2003, 08:18 PM
mikemover's Avatar
All-seeing, all-knowing.
 
Join Date: Aug 2001
Location: Atlanta, GA
Posts: 5,514
It's a rare, horrible and expensive suspension problem, and it will cost you more than the car is worth to you, so I'll help you out and buy the 6.9 from you for $500!

Mike
__________________
_____
1979 300 SD
350,000 miles
_____
1982 300D-gone---sold to a buddy
_____
1985 300TD
270,000 miles
_____
1994 E320
not my favorite, but the wife wanted it

www.myspace.com/mikemover
www.myspace.com/openskystudio
www.myspace.com/speedxband
www.myspace.com/openskyseparators
www.myspace.com/doubledrivemusic
Reply With Quote
  #4  
Old 01-15-2003, 07:48 AM
fritzthetiger
Guest
 
Posts: n/a
Not suspension

Sorry, nice try. It's not the suspension, that's brand new.
Reply With Quote
  #5  
Old 01-15-2003, 10:51 AM
mikemover's Avatar
All-seeing, all-knowing.
 
Join Date: Aug 2001
Location: Atlanta, GA
Posts: 5,514
Hahaha...Hey, you can't blame me for trying, right?

Did you find out what actually is wrong yet? It does seem like it might be a parking-brake problem, or a frozen caliper.

I hope you don't have to drive that car in the snow and salt too much up there...116s are BAD BAD BAD about rusting!

Mike
__________________
_____
1979 300 SD
350,000 miles
_____
1982 300D-gone---sold to a buddy
_____
1985 300TD
270,000 miles
_____
1994 E320
not my favorite, but the wife wanted it

www.myspace.com/mikemover
www.myspace.com/openskystudio
www.myspace.com/speedxband
www.myspace.com/openskyseparators
www.myspace.com/doubledrivemusic
Reply With Quote
  #6  
Old 01-15-2003, 04:26 PM
fritzthetiger
Guest
 
Posts: n/a
No:

It's a collector. I've been rebuilding it from the bottom up. Thanks though.

PS Used to live not too far from you in NC.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page