Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 10-04-1999, 06:25 PM
Registered User
Join Date: Sep 1999
Location: Los Angeles, CA, USA
Posts: 32
I have an 87 260E. None of the power windows work. I have checked the two fues that control the windows and they are both not blown. I took a volt meter to the fuses and there is no voltage going through the fuses at anytime (with the car on, off, the switch for the windows depressed). Is there a relay controlling all the windows that can be bad? Where is it located?

Another thing, my center air conditioning vents have no air coming out of them no matter what my settings are. Could there be a bad vacuum hose somewhere that is not causing this vent to open? Where do I look?
Thanks for any replies.
Old 10-04-1999, 06:35 PM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
For the window try to replace the fuse first.
air condition center vent not opening you must have vacuum leak it could be elements you need testing tool to check the system find a shop check for you.
hope this help.

MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
Old 10-04-1999, 09:03 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You should replace the fuses even though they appear to be OK. Trust me they might cause this. There could be a vacuum leak in the engine compartment causing the Klima problem/

1981 280GE SWB
1987 16V

Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mercedes Power windows tkotanch Tech Help 6 12-16-2004 11:08 PM
Power windows slow down, seem "tight" in the middle. nglitz Tech Help 17 11-23-2004 12:38 AM
260e Power Loss & Odd Smell stevenstevensteven Tech Help 3 10-25-2003 05:47 PM
Installing PowerWindows Captain-X Tech Help 1 09-03-2001 04:37 PM

All times are GMT -4. The time now is 09:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page