Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 10-06-1999, 07:49 AM
Registered User
Join Date: Jul 1999
Location: RI
Posts: 45
84 300 CD..When driving, with the temp control on max, (and any of the air position buttons pushed)the fan blows plenty of cool air. If I stop and idle, then suddenly there's loads of hot temp heat from whatever position I choose. Get back on the road and it cools back down... While I wait for my service CD, is there anything I can look at immediately (there's frost on the ground now when I leave for work in the AM)
Old 10-06-1999, 09:11 PM
Posts: n/a
Remove the mono valve insert and inspect the diaphram for tears. I suspect that you will find one. Replacement is the repair. A kit is avilable with a new insert. No need to replace the complete valve.
Good Luck.
Old 10-07-1999, 08:19 AM
Registered User
Join Date: Jul 1999
Location: RI
Posts: 45
Corky: What is the mono valve and where is it located? Hate to sound clueless but in this case
No CD = no clue
Old 10-08-1999, 11:06 AM
Posts: n/a
The mono valve is located on the fire wall just to the left of the battery. It has a two pin connector on the top with a cover that has four screws holding it down. It has coolant lines (three) attached to the lower part of it (plastic) Removal of the four screws on the top plate is all that is required to remove the insert and inspect.
Good Luck.
Old 10-08-1999, 11:48 AM
Posts: n/a
My 83/300CD had the same problem last winter and what Corky explained was the fix for my car.

Good Luck
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mystery Solved - But Problem persists pberku Diesel Discussion 3 08-31-2004 02:15 AM
1992 300CE W124 Doorlock Problem Ashman Tech Help 10 07-31-2004 09:37 PM
M103 Hesitation Problem Fixed! John Plut Tech Help 1 01-06-2004 07:31 PM
1992 500SL ASR System Problem jrodnar SL Forum 3 04-05-2003 02:34 PM

All times are GMT -4. The time now is 08:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page