Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 10-18-1999, 05:08 PM
Posts: n/a
I have many problems with my '94 E420. I will start with the intermittent problems that can happen between startings or in the middle of a Sunday drive. Sometimes they work, sometimes they don't.

- Automatic window down switch for the driver and front passenger
-Air recirculation switch
-Rear defrost
-Idle speed accuator
-Sunroof auto close
-SRS light
-Lights behind the AC cluster

I also seem to burn through tail lamps at an alarming rate. Sometimes the car will forget that there is someone depressing the gas peddle and just lose power until I can deliver a power surge. I can do this by flashing the high beams or cycling the AC motor. The check engine light is always illuminated. I have had the codes pulled, but with differing results each time. I am sad to say the mechanics seem to use their computer more than their brains.

There seems to be no pattern to this mayhem.

Please email me at if you have advice or a solution other buying a new car.

John Kurtz
Art Director
P.O Box 3600
37347 U.S 6, Suite 110
Avon, CO 81620

Old 10-18-1999, 07:39 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like you have a charging system problem. The voltage supply needs to be somewhat constant & steady. Possibly the voltage regulator is sticking, also have the ground connections checked. This is normally a very dependable car.
Old 10-18-1999, 08:20 PM
Larry Delor's Avatar
What, Me Worry?
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,028

An easy way that I know of to help determine excess voltage leaving the alternator, is to check the battery...If it is spewing out acid (wetness/visible splatter marks), or if the battery sides seem bulged(from the heat produced by the excessive voltage) then I would point the finger at the alternator.
Hope this gets you somewhere!

'83 300D

Old 10-20-1999, 03:31 AM
Registered User
Join Date: Mar 1999
Location: Atlanta, Georgia, USA
Posts: 1,342
Without doubting the wisdom of MB DOC...has your car been checked for the dreaded W124 cracked wiring harness problem? The V8's suffered from it just as the 6's. I've experienced such a problem causing a wide range of screwy behaviors in a 500E. Talk to your local dealer on replacement. MB may or may not replace on goodwill. I was fortunate that my local dealer did 100% on goodwill on a car that had 125K miles. They don't have an obligation past the normal warranty, but check with your dealer for possible goodwill. Its a common enough problem that an experienced tech should be at least somewhat familiar with it.

Hope this helps...Lee
Old 10-20-1999, 09:57 PM
Posts: n/a
Lee, are you able to elaborate on the potential locations of the cracked wiring
harness and in what areas might you experience problems. In particular I wonder about intermittent check engine light on an 88 124 3.0. thanks...Sydney.
Old 10-21-1999, 08:06 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
See tech tips for info on cracked wiring harness. Production dates 8/92-4/95. Not all cars received this type of engine wiring.
The problems with engine wiring harness don't affect other parts of the cars electrical system.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 1997 E420 (Sport) Known Problems? kowached Tech Help 2 04-14-2002 10:27 PM
Problems on e420 tranny jchowe420 Tech Help 2 10-21-2001 12:29 PM
e420 drivabilty problems!!! chadman Tech Help 1 08-23-2001 12:20 AM
97 E420 Sport Bushing/Control Arm Problems ZuMBLe Tech Help 14 02-25-2001 01:34 AM
1997 E420 (Steering Problems) Aeen Tech Help 6 05-10-1999 03:59 PM

All times are GMT -4. The time now is 09:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page