Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-04-2003, 05:55 AM
Registered User
Join Date: Jan 2002
Location: Hong Kong
Posts: 47
Suspension Question

Hello All,

I have just bought my first SL. A 1992 500 model. Its a nice machine and drives brillantly, however I do have a question on the suspension.

When driving on rougher roads there is a slight clicking noise coming drom the underside of the car, which I think is suspension related. Is this a normal occurence??


1992 500 SL
1992 600 SEL
Vince Alfonso (in Hong Kong)

92 MB 600 SEL
94 MB 600 SL
92 MB 500 SL (for sale)
93 BMW 740i
Reply With Quote
Old 02-04-2003, 06:12 AM
slk italy
Posts: n/a
Suspension Question

i think it my be your exaust system... check it
Reply With Quote
Old 02-04-2003, 07:51 AM
Registered User
Join Date: Sep 2002
Location: Winston-Salem, NC
Posts: 71
I had a similar problem on my '86 560SL and had the subframe mounts replaced. Fixed the problem but was quite expensive due to labor (the parts are cheap if you can do it yourself).

Good luck,
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page