Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-05-2003, 06:51 PM
Registered User
Join Date: Feb 2003
Location: Ohio
Posts: 66
Heater problems 280SEL

I have a 1984, 280 SEL . The heater puts out cold air when the car is on the road. If I let the car warm up to operating temp the heater works ok, shortly after the car is moving the heater blows cold air. I have checked the solenoid controlled heater valve and the electric circulating pump both work ok. The heater valve energizes and de-energizes when the switches on the climate control are operated. I checked the hoses and heater core and they are not blocked. I think the thermostadt is ok because the car comes up to operating temp and the hoses are warm to the touch. Is there a way for cold air to enter the duct work if maybe a door/flap is sticking? When the switches on the climate control are operated airflow switches from dash to windshield so I think they are working. Any help would be appreciated.
Thanks, Bob
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:11 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page