Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-08-2003, 03:54 PM
d-money's Avatar
Registered User
 
Join Date: Feb 2003
Location: Foley,AL.
Posts: 54
no buzz

I have a 77 280 SE when I turn the key on should the fuel pump come on for a few seconds? Could my fuel pump relay be bad, the car will not stay cranked unless I dump fuel in the intake a few times, but once it is running it runs fine
__________________
[img]ftp.m3paintball.com/%2Fm3/m3paint/benzsig.jpg[/img]
Reply With Quote
  #2  
Old 02-08-2003, 07:09 PM
d-money's Avatar
Registered User
 
Join Date: Feb 2003
Location: Foley,AL.
Posts: 54
anything?????
__________________
[img]ftp.m3paintball.com/%2Fm3/m3paint/benzsig.jpg[/img]
Reply With Quote
  #3  
Old 02-09-2003, 01:09 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Sounds like a fuel pump. When was the fuel filter replaced last?

Keep us posted,

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page