Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2000, 09:34 PM
Registered User
 
Join Date: Jan 2000
Location: Pittsburgh, PA, USA
Posts: 86
Please bare with me. I have had several new BMW's but am new to MB. I just picked up an 84 500sl. When cold the car starts right away but will stall within 8-10 seconds. Depressing the accelerator will cause it to stall immediately. After maybe 10 retries the car will run and once warm will has no hesitation and sounds strong. I have noticed a leak on the rear passenger side of the car from what looks to me to be an electric fuel pump. I'm just getting started with these cars so any help available would be greatly appreciated.

Thanks

Marc
Reply With Quote
  #2  
Old 01-07-2000, 09:57 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Check the accumulator. If there is a fuel leak, you are having a problem building fuel pressure. Also if the car has a warm up regulator, it can go south.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #3  
Old 01-08-2000, 10:46 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Many of the euro cars had bad conversions done to fuel system to bring emission system up U.S. standards. Sounds as though the car is running too lean ie; fuel pressure problem (warm-up regulator). Have the fuel pressures checked.

On the fuel pump there are copper crush seals that leak, easy to reseal.

[This message has been edited by M.B.DOC (edited 01-08-2000).]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'87 300E Stalling Garth Tech Help 21 09-11-2008 10:03 PM
500SL good years? bad years? spinedoc Tech Help 4 11-04-2002 05:57 PM
Correlation between high engine temps and stalling? screedchan Tech Help 7 08-27-2001 01:24 PM
stalling in an '83 500SL bliang Tech Help 2 05-05-1999 05:47 PM



All times are GMT -4. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page