Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2003, 08:45 PM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
weak starting

I was wondering if any could tell me what causes the engine to rev up higher when starting, and then drop down to idle speed.

my 1985 190E 2.3 8vlv has a really rough time doing this when I start it and I would like to cure this problem, sometimes on a start, even though it starts up right every time, it will die, on second start it will be just fine, but it never starts up propperly when cold.

This is what I would expect, from 0 rpm to 1500rpm, and then hold it there for a second or two, and drop down to 1000rpm for warm up and then after it warms up to 650rpm all in idle of course. my car does 0 to 650 very slowly as if it's struggling with something, if it does not die here, it will go to a 1000rpm and stay there until it is warm, then back to 650rpm.

Can anyone explain the theory behind this? would love to fix this, maybe something is leaking in my car that I should take a look at, injectors are clean, but it's as if it lost pressur right after you start it up, but I know it does not lose pressur, I tested it.

xp
Reply With Quote
  #2  
Old 03-15-2003, 02:00 AM
sflori
Guest
 
Posts: n/a
Sorry I can't really help you except to say that this is typical of 190s. Mine is the same way. It's more difficult to start when it's cold and especially if it's also wet.

There is some kind of valve in the engine that controls the ratio of air to fuel which sometimes can go bad. From my understanding, it's a very labor intensive job to fix which will run more than a$1,000. Hope that's not what's wrong with your car.
Reply With Quote
  #3  
Old 03-15-2003, 10:31 AM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
Here is how our '91 190E 2.3 behaves, since I fixed the idle. Note that the idle circuit of yours is a different design (I believe). When the engine is first started cold, idle goes to about 1200 rpm - not racing, idling smoothly - then drops to 750 rpm in 5 - 20 sec. Idle may go a bit higher, maybe 850, for awhile if it is pretty cold out.

If you have an idle control valve, it may be gummy and need cleaning. Injector cleaner in the fuel tank will NOT do this, it must be removed. If the connecting hoses are hardened with age, they should all be replaced, and I found the OVP relay apparently had bad contacts. Also check for proper operation of thermostatic elements and check for vacuum hoses loose.

Steve
Reply With Quote
  #4  
Old 03-15-2003, 10:46 AM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
Circuits circuts circuits....

Thanx a lot for the advice, so far, I have done most of those things, but I'm not sure to what valve you are referring to sflori, to control the air/fuel mixture I only know of the EHA, and idle control valve, one takes care of it at idle, the other while driving, if there is another one I'd love to know where I can find it, I'm sure it needs a good cleaning, temperature sensors might have something to do with it I completely agree, I will look into replacing mine soon, the parts list goes on he he he

Actually, I noticed that this started happening after I cleand the idle control valve, it's almost like it needs the second try to catch on propperly because it's reaction is delayed by something, go figure...

come summer time I'll be taking the entire car apart, maybe I'll find what's causing this.

xp
Reply With Quote
  #5  
Old 03-15-2003, 01:02 PM
sflori
Guest
 
Posts: n/a
XP,

I'll give my mechanic a call to see what valve it is. I really don't remkember if it's a valve or something else. The "idle control valve" that sborg mentioned sounds familiar, but I'm not sure.

I won't be able to call him until Friday, though, as I'll be in CA directing a promotional film for the USMC until Thursday night.
Reply With Quote
  #6  
Old 03-15-2003, 07:59 PM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
great :)

That would be great sflori, I would really appreciate it, I'm sure a lot of people on this forum would be able to answer this too.

directing sounds great, hope it all goes well.

xp
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page