Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2003, 05:28 PM
yel_low
Guest
 
Posts: n/a
Automatic Gearbox Problems!

hey there!
im having some troubble with my 300D -88 with 4 steps aut, when i hit "D" it starts on third GEAR.. if i hit "3" it starts on the second gear...

what is common is that it "spinns" in the gears a little, and if i go on 2:nd gear and when it shifts up to the 3:rd gear and right after(2secs?) than it goes to the 4:th gear(D)...

i have NEW oil and filter(OEM) in gearbox, and of course correct volume oil.(CASTROL TQ DEXRON III)


i woundering if my "valve package" may be bad?


also if i have in "P" and moves the shift to a gear it almost "kicks" in the gear, no mather what gear it is or reverse, same "kick".

my idle is NOT to high, it is correct.


hopes someone can help my with my problem!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page