Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-08-2003, 09:45 PM
digdig
Guest
 
Posts: n/a
Talking a thank you

I just wanted to thank everyone for the help in curing my idle problems. It turned out the previous owner decided to mess with some base settings in the system. After finding a broken wire in the td signal feed from the ign. module, the car would stay at idle. It did however idle fast at about 1200 rpm. After replacing the idle control valve, the EHA, and the temp. sender the car ran alot smoother but still idled high(1000 rpm). I then decided to rebuild and clean the entire injection system. Upon doing this I found the butterfly flap in the lower chamber had the flap stop adjusted incorrectly. After readjustment of this and the mixture the car runs like a dream. Thanks to the input I got here and the patience of my wife not seeing me because I was in the garage I was able to save a ton of money by not taking the car to the dealer, and can once again enjoy this fabulous car. MANY THANKS TO ALL !!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page