Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-09-2003, 12:45 PM
Registered User
Join Date: Feb 2002
Location: Kingston NY
Posts: 114
190e Alternater ?

My 1985 2.3 8V starts slowly (like low battery) and seems to have less battery charge after running for a while. Battery is new. When the car is running at 1100 rpm, voltage at battery terminals is 12.84. If I rev to 3000 or so it jumps to 13.25 or there abouts. I replaced the regulator a couple months ago and have 3 hours of running time on the car since then. I think I need a NEW alternater. Am I thinking correctly?
Reply With Quote
Old 04-09-2003, 01:16 PM
csnow's Avatar
Registered User
Join Date: May 2002
Location: Mass
Posts: 1,127
I'd say you are in spec. with those readings.

Try it again at idle with the rear defog on, high beams on, and blower fan on high. See if it can keep its head above water under load.

'3 hours of running time in a couple of months' might say it all, though. There is substantial 'static' drain from sitting still. That may not be enough run time to keep the charge up.
1986 300E 5-Speed 240k mi.
Reply With Quote
Old 04-09-2003, 02:24 PM
Registered User
Join Date: Feb 2002
Location: Kingston NY
Posts: 114
What I meant by 3 hours is that the car has not been driven since the new brushes (indicating that tey could not need replacement again). I drove it all of 5 miles since the new brushes (car has been driven LESS than 200 miles in the last year). The battery however is brand new and is the second new battery for the car in a year. I thought the battery I bought last year may have gone bad, so I got a new one last week.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page