Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-27-2003, 06:12 AM
Registered User
Join Date: Oct 2002
Posts: 188
W140 Injectors Leak

I have a W140 with M104 engine.

I have a, what I suspect, a injector leak as the #5 injector have black oil all around the outside (just by looking) while all others are just dust.

I will properly get a mechanics to replace the injectors as its a 1992 car. However I read that there are other plastic, housing, hose, vacum that should be replaced as well.

Can someone explain what I need to tell the mechanic to replace?

Any idea of cost?

Reply With Quote
Old 04-27-2003, 06:13 AM
Registered User
Join Date: Oct 2002
Posts: 188
Realise I posted on the wrong board. I think this is more approporate

Hagies thanks for your reply. Truely value your help in this regards.

Jim, thanks for your note. Yes without you pointing the point out, I didn't realise I posted in the wrong board. Mine is a "Petrol" engine and thanks for correcting me in this regards. Still running very HAPPY with your excellent cool harness.

What Hagies point out is true, I properly should't replace things because of its a 1992 car. In fact I don't seem to have any of the "Bad Injectors" symptom as discussed in detail in this web site. My idle speed is around 600 rpm and I don't get any vibration nor any hestitation. (I think these are the symptom)

In fact I found this "so called" leak from visual inspection rather than idle hestitation or poor start problems.

Out here where I am, the mechanics will always say "replace the lot" I wanted to get some opinions from expert here in regards to what really should be replaced. I hate to replace something that does not need replacing at all. Worst still, the mechanics will charge $$ labor with no value add!!

OK my problems?? just a visual leak, I think. One of the injector, #5, has black oil all around it and in areas near-by including the harness connection. I am worried that this may lead to bigger problems and thus want to get a mechanic to fix it ASAP. Should I not worry? How involve is this? Should I post a picture?

All help are greatly appreciated. Thanks to all of you!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page